After backup restore, addon domains are not shown in cpanel!

MaRiOsGR66

Well-Known Member
Feb 18, 2011
111
1
68
cPanel Access Level
Root Administrator
I did a full restore of a weekly backup of an account with 7-8 addon domains.
After the restore, I check the user's cpanel account and there are 0 addon domains...
but in his /home/user/public_html/ I can see all the domain folders of the addon domains.

Why did this happen?
how can I fix it ?
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,228
463
Hello :)

I suggest checking the cPanel user file to see if the addon domain names are listed:

Code:
/var/cpanel/users/username
If the entries do not exist, it's possible there were some errors during the restore process. If you would like us to try restoring the account again to check for any specific errors, feel free to open a support ticket:

Submit A Ticket

Thank you.
 

MaRiOsGR66

Well-Known Member
Feb 18, 2011
111
1
68
cPanel Access Level
Root Administrator
It didn't work because I didn choose to restore subdomains,
which was confusing because subdomains and addon domains are 2 separate things

for the domain:
domain1.tld
these are subdomains:
test.domain1.tld
forum.domain1.tld

but for an account with addon domains liek
domain1.tld
domain2.tld
domain3.tld
these are not subdomains, but addon domains, and I think this should be described in the restore util.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,228
463
To confirm, you would like to see the "Restore Backups" option in Web Host Manager clarify that addon domain names will not be restored if "Restore Sub-domain Entries" is not selected? If so, could you submit a bug report?

Submit A Bug Report

All bug reports are handled internally. This will allow us to reproduce the issue, and provide you with an internal case number for tracking.

Thank you.