The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

After CP11 upgrade: 404 error while loading any site.com/cpanel/

Discussion in 'General Discussion' started by sh4ka, Jun 10, 2007.

  1. sh4ka

    sh4ka Well-Known Member

    Joined:
    May 12, 2005
    Messages:
    442
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    US
    cPanel Access Level:
    DataCenter Provider
    That..

    After upgrading to cPanel 11 ( did all steps in the checklist ) i can not login using site.com/cpanel & site.com/webmail , but i can login using https://site.com:2083/ and http://site.com:2082/, same as webmail at 2095 and 2096.

    Im using RHEL 4 and latest cp v11 RELEASE

    Any ideas ?

    Thanks.
     
  2. Mal

    Mal Member

    Joined:
    Sep 4, 2004
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    I recently got a new server and had this same problem (since version 11 was installed by default). I ended up getting the datacentre to look into it, but apparently some lines were missing from httpd.conf. I have also been having trouble with creating accounts in WHM, as it was crashing apache because certain modules were not being loaded via httpd.conf.
     
  3. sh4ka

    sh4ka Well-Known Member

    Joined:
    May 12, 2005
    Messages:
    442
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    US
    cPanel Access Level:
    DataCenter Provider
    I think the lines at httpd.conf that you said are this :

    ScriptAlias /cgi-sys/ /usr/local/cpanel/cgi-sys/
    Alias /sys_cpanel/ /usr/local/cpanel/sys_cpan
    ScriptAliasMatch ^/cpanel/(.*) /usr/local/cpanel/cgi-sys/redirect.cgi
    ScriptAlias /cpanel /usr/local/cpanel/cgi-sys/redirect.cgi
    ScriptAlias /whm /usr/local/cpanel/cgi-sys/whmredirect.cgi
    ScriptAlias /securewhm /usr/local/cpanel/cgi-sys/swhmredirect.cgi
    ScriptAlias /webmail /usr/local/cpanel/cgi-sys/wredirect.cgi
    ScriptAliasMatch ^/webmail/(.*) /usr/local/cpanel/cgi-sys/wredirect.cgi

    Added this to httpd.conf, and got this issue fixed :D
     
  4. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    /usr/local/cpanel/setupapache will fix this automaticlly
     
  5. mdelacruz

    mdelacruz Member

    Joined:
    Apr 24, 2004
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    I solved the same problem

    I solved this same problem creating DNS zone for my server (Add A entry for this host) and dns zones for my own DNS
     
Loading...

Share This Page