After installing MailScanner can`t send/receive mails

the_bobara

Well-Known Member
PartnerNOC
Sep 23, 2004
92
0
156
Bulgaria
cPanel Access Level
Root Administrator
hello,
after installing MailScanner I can`t send/receive mails...
i mean I send/receive them (that logs show), but in my mailbox there is nothing?
how to fix that....i do search in this forum but all thing i saw didn`t help...
Please Help me!!!
 

chirpy

Well-Known Member
Verifed Vendor
Jun 15, 2002
13,437
33
473
Go on, have a guess
If you installed using my installer script, you should check in /var/log/maillog for MailScanner errors. Feel free to contact me off-forum for help.
 

sawbuck

Well-Known Member
Jan 18, 2004
1,365
10
168
cPanel Access Level
Root Administrator
the_bobara said:
how to uninstall exim, MC, calm and install it again using Chirpy`s method ?
In the install directory that is created using the hostinglife info is an uninstall script. Run that to remove MailScanner.
 

kickedmydog

Well-Known Member
Oct 28, 2004
65
0
156
No more emails after install

I installed MailScanner and ClamAV to the exact directions posted at http://www.configserver.com/free/mailscanner.html and when watching tailing the log files i saw my pop authenticatsions and when I sent test mails from my ISP and Gmail, I saw them hit the server but no mail was coming through at all.

Uninstalled mail scanner and re-instated all my old settings and everything came in for delivery.

Cpanel has ClamAV now as an option in WHM. Can this work instead? Also if I have installed ClamAV manually, how do I uninstall it without a script?

Thanks,

Brad
 

chirpy

Well-Known Member
Verifed Vendor
Jun 15, 2002
13,437
33
473
Go on, have a guess
You can clean your server of ClamAV with:
Code:
killall clamd

/bin/rm -Rfv /usr/bin/clam*
/bin/rm -Rfv /usr/sbin/clam*
/bin/rm -Rfv /usr/lib/libclam*
/bin/rm -Rfv /usr/share/clam*
/bin/rm -Rfv /usr/include/clam*
/bin/rm -Rfv /usr/bin/freshclam*
/bin/rm -Rfv /usr/etc/clamav*

/bin/rm -Rfv /usr/local/bin/clam*
/bin/rm -Rfv /usr/local/sbin/clam*
/bin/rm -Rfv /usr/local/lib/libclam*
/bin/rm -Rfv /usr/local/share/clam*
/bin/rm -Rfv /usr/local/include/clam*
/bin/rm -Rfv /usr/local/bin/freshclam*
/bin/rm -Rfv /usr/local/etc/clamav*
I can assure you that the directions on th sit for installing MailScanner are correct, though they cannot cater for every single environment. Whenever I've seen it not work, it's been down to a problem with the perl installation. Could have helped you out if asked ;)

The Clamavconnector in WHM Add-ons does indeed provide for virus scanning of emails.