The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

After installing Tomcat, apache failes

Discussion in 'EasyApache' started by flashweb, Apr 25, 2003.

  1. flashweb

    flashweb Well-Known Member

    Joined:
    Mar 13, 2003
    Messages:
    243
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    Hi,

    I have installed

    jsp-install-3.x.tar.gz

    from layer1.

    After installing Apache failed to start.

    /etc/rc.d/init.d/httpd start

    says

    httpd could not be started.

    service httpd status

    SAYS

    looking up localhost
    localhost
    Making HTTP connection to localhost
    Alert!: Unable to connect to remote host.

    lynx: can't access startfile http://localhost/server-status

    What to do ?

    Now i can't get sites from the server.

    Regards,

    Yujin Boby
     
  2. mitul

    mitul Well-Known Member

    Joined:
    Feb 8, 2003
    Messages:
    291
    Likes Received:
    0
    Trophy Points:
    16
    tail the contents of error_log and paste them here.
     
  3. flashweb

    flashweb Well-Known Member

    Joined:
    Mar 13, 2003
    Messages:
    243
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    tail error_log



    [Fri Apr 25 06:06:45 2003] [emerg] Error while opening the workers
    [Fri Apr 25 06:15:08 2003] [emerg] Error while opening the workers
    [Fri Apr 25 06:15:08 2003] [emerg] Error while opening the workers
    [Fri Apr 25 06:15:08 2003] [emerg] Error while opening the workers
    [Fri Apr 25 06:23:31 2003] [emerg] Error while opening the workers
    [Fri Apr 25 06:23:31 2003] [emerg] Error while opening the workers
    [Fri Apr 25 06:23:31 2003] [emerg] Error while opening the workers
    [Fri Apr 25 06:31:54 2003] [emerg] Error while opening the workers
    [Fri Apr 25 06:31:54 2003] [emerg] Error while opening the workers
    [Fri Apr 25 06:31:54 2003] [emerg] Error while opening the workers
     
  4. mohamed_gaber

    mohamed_gaber Member

    Joined:
    Mar 4, 2003
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    sorry guys, i've tried to search for TomCat and know "what it is" but i couldn't

    can u please tell me what does it do ? and why it's that pop.

    sorry again and hope u have this prob. fixed.
     
  5. flashweb

    flashweb Well-Known Member

    Joined:
    Mar 13, 2003
    Messages:
    243
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    TomCat is installed to run JSP/Servlet on web server.

    No, still the problem is not solved.

    I am trying to install Apache now

    bash buildapache.sea

    that is running for hours now, doing for the first time, don't know it take too much time.

    Now its doing

    Scanning suexec_log...Done
    Scanning suexec_log...Done
    Scanning suexec_log...Done
    Scanning suexec_log...Done
    Scanning suexec_log...Done
    Scanning suexec_log...Done
    Scanning suexec_log...Done
    Scanning suexec_log...Done
    Scanning suexec_log...Done
    Scanning suexec_log...Done
    Scanning suexec_log...Done
    Scanning suexec_log...Done

    for long time.

    Don't know what it is doing :)

    Regards,

    Yujin Boby
     
  6. vishal

    vishal Well-Known Member

    Joined:
    Jan 28, 2003
    Messages:
    340
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    Same Here!!!

    Hello,

    Yesterday I compiled Apache with easyapache. The compilation was successful but after the httpd restart. The Message "Scanning Suexec Log.....Done" Started and it went on and on and on and on...........

    This happend on 3 of my servers RH 7.3.

    Regards,


    :rolleyes:
     
  7. flashweb

    flashweb Well-Known Member

    Joined:
    Mar 13, 2003
    Messages:
    243
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    Same here.

    Scanning suexec_log...Done
    Scanning suexec_log...Done
    Scanning suexec_log...Done
    Scanning suexec_log...Done
    Scanning suexec_log...Done
    Scanning suexec_log...Done
    Scanning suexec_log...Done
    Scanning suexec_log...Done
    Scanning suexec_log...Done

    is continuing....

    After reinstalling i can't get apache running.

    When i try to restart "Apache" through WHM it says

    ===========
    Waiting for httpd to restart.... . . . . . . . . . . finished.
    httpd status
    httpd has failed, please contact the sysadmin.
    ===========

    root@server2 [~]# service httpd status

    Looking up localhost
    localhost
    Making HTTP connection to localhost
    Alert!: Unable to connect to remote host.

    lynx: Can't access startfile http://localhost/server-status

    ===========

    root@server2 [~]# service httpd stop
    /etc/init.d/httpd stop: httpd (pid 963?) not running

    ===========

    root@server2 [~]# service httpd start
    /etc/init.d/httpd start: httpd could not be started

    ===========

    root@server2 [/usr/local/apache/logs]# tail error_log
    [Fri Apr 25 13:56:39 2003] [emerg] Error while opening the workers
    [Fri Apr 25 14:05:02 2003] [emerg] Error while opening the workers
    [Fri Apr 25 14:05:02 2003] [emerg] Error while opening the workers
    [Fri Apr 25 14:05:02 2003] [emerg] Error while opening the workers
    [Fri Apr 25 14:13:12 2003] [emerg] Error while opening the workers
    [Fri Apr 25 14:13:17 2003] [emerg] Error while opening the workers
    [Fri Apr 25 14:13:25 2003] [emerg] Error while opening the workers
    [Fri Apr 25 14:13:25 2003] [emerg] Error while opening the workers
    [Fri Apr 25 14:13:25 2003] [emerg] Error while opening the workers
    [Fri Apr 25 14:18:17 2003] [emerg] Error while opening the workers

    ===========

    Any suggestions ?

    Regards,

    Yujin Boby
     
  8. flashweb

    flashweb Well-Known Member

    Joined:
    Mar 13, 2003
    Messages:
    243
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    Thanks for the reply.

    I Commented out

    #AddModule mod_jk.c

    and

    #LoadModule jk_module libexec/mod_jk.so

    now Apache is back normal.

    Do i need to uninstall jsp 3 before installing jsp 4 ?

    If yes, how ?

    Regards,

    Yujin
     
  9. xp2u

    xp2u Active Member

    Joined:
    Jan 27, 2003
    Messages:
    41
    Likes Received:
    0
    Trophy Points:
    6
    Just Install version 4

    Just install version 4. It will over-write version 3. And Jsp wil lbe working but not servlet.
     
Loading...

Share This Page