The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

After SSL Installed on Exim, Can't Send to Remote Host

Discussion in 'E-mail Discussions' started by mitchkill, Oct 26, 2015.

  1. mitchkill

    mitchkill Member

    Joined:
    Dec 26, 2008
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Hello Everyone,
    I've run into a curious situation with Exim and a signed certificate.

    I have a server (cpanel v11.52.0 build 18)that runs an issues tracker for my business, we'll call the host name vm1.domainname.com and the issues tracker domain name projects.domainname.com. I have a separate mail server that needs to receive the e-mail notices from the e-mail tracker. The domain name for the mail server is mail.domainname.com.

    In projects.domainname.com, I put in my mail server's SMTP information and wasn't able to connect due to a SSL error from the remote server. I thought this might be related to the system's SSL certificate so I decided to install a signed certificate.

    Because I don't want to spend tons of money on SSL certificates, I purchased a UCC multi-domain certificate. This multi-domain certificate includes domainname.com, mail.domainname.com, projects.domainname.com, and vm1.domainname.com. I logged into WHM, and went to Service Configuration->Manage Service SSL Certificates and installed this certificate there. Now when I try to setup projects.domainname.com to send to my mail server, the SMTP connection is rerouted to the local Exim server. It refuses to go to the remote server whether i use mail.domainname.com or the IP address instead just going to the local Exim server. If I use the IP address, I get the following message in exim_mainlog. If I use the domain name, I'm told that authentication failed (because it is checking on the local server).

    2015-10-26 18:50:01 SMTP connection from [xx.xxx.xx.xxx]:44946 (TCP/IP connection count = 1)
    2015-10-26 18:50:01 SMTP connection from vm6.domainname.com [xx.xxx.xx.xxx]:44946 lost (error: Connection reset by peer)
    2015-10-26 18:51:07 SMTP connection from [127.0.0.1]:59936 (TCP/IP connection count = 1)
    2015-10-26 18:51:07 SMTP connection from localhost [127.0.0.1]:59936 closed by QUIT

    I checked Tweak Settings->Mail and changed "Restrict outgoing SMTP to root, exim, and mailman (FKA SMTP Tweak) " to disabled. I also made sure that any DNS entries were set to use remote mailers. I'm not sure what to do next! Any ideas?
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,723
    Likes Received:
    660
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
  3. mitchkill

    mitchkill Member

    Joined:
    Dec 26, 2008
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Thanks for getting back to me. Oddly enough, this just started working. I'm honestly not sure why it is, but it is. I don't know if an automated update fixed the SSL or what. The domain name was in /etc/remotedns like it is supposed to be. Anyway, it works now. Thanks for jumping in!

    Mitchell
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,723
    Likes Received:
    660
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
Loading...

Share This Page