The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

after update to 9.30.0. R4 with the Exim fix no more message ids are being sent

Discussion in 'General Discussion' started by cyberspirit, May 12, 2004.

  1. cyberspirit

    cyberspirit BANNED

    Joined:
    Jun 27, 2003
    Messages:
    293
    Likes Received:
    0
    Trophy Points:
    0
    After upgrading to 9.3.0. R4 with the Exim fix to 4.32 it seems that Exim no longer sends out message ids as part of the header and messages bounce at systems that check for this.

    See an example of an email to the exim user group here:

    exim-users-request@exim.org
    SMTP error from remote mailer after end of data:
    host mail.exim.org [195.92.249.251]: 550-Message SHOULD have Message-ID:
    but does not
    550 Most messages without it are spam, so your mail has been rejected.


    I have added a bug report here:

    http://bugzilla.cpanel.net/show_bug.cgi?id=580
     
  2. ciphervendor

    ciphervendor Well-Known Member

    Joined:
    Aug 26, 2002
    Messages:
    1,052
    Likes Received:
    0
    Trophy Points:
    36
    /scripts/updatenow
    /scripts/exim4
     
  3. cyberspirit

    cyberspirit BANNED

    Joined:
    Jun 27, 2003
    Messages:
    293
    Likes Received:
    0
    Trophy Points:
    0
    thanks, lol, but reinstalling exim is not the solution. it is actually more complex than that and some people behind exim are looking into it.
     
  4. tAzMaNiAc

    tAzMaNiAc Well-Known Member

    Joined:
    Feb 16, 2003
    Messages:
    559
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Sachse, TX
    I think something's wrong with your config?

    I have Message-ID's just fine in my setup, and I'm at 9.3.0 R5. You say you are at R4? That's probably why cipher said upgrade.

    Message-Id: <20040516032454.M83414@deafnetwork.com>

    Is one example from one of my emails....Sure looks fine to me. Maybe you run on a different platform from linux?

    Brenden
     
  5. icanectc

    icanectc Well-Known Member

    Joined:
    Mar 10, 2003
    Messages:
    344
    Likes Received:
    0
    Trophy Points:
    16
    I think you maybe referring to this

    Goto Tweak Settings

    Make sure you checked

    Track the origin of messages sent though the mail server by adding the X-Sender headers..

    Is that what you are talking about.. By Default its off.
     
  6. cyberspirit

    cyberspirit BANNED

    Joined:
    Jun 27, 2003
    Messages:
    293
    Likes Received:
    0
    Trophy Points:
    0
    no, a message ID has nothing to do with an X-Header. X-Headers are custom and injected whereas other headers are rfc defined.
     
Loading...

Share This Page