Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SOLVED After upgrade to build 64 - 13 can't FTP fails SSL connect

Discussion in 'General Discussion' started by vincentg, Apr 19, 2017.

  1. vincentg

    vincentg Well-Known Member

    Joined:
    May 12, 2004
    Messages:
    143
    Likes Received:
    3
    Trophy Points:
    168
    Location:
    new york
    On all servers after this upgrade we can not connect to FTP using SSL

    TLS Cipher Suite is set to default cpanel settings

    TLS Encryption Support has to be set to optional as forcing to SSL does not work.

    Worked fine before the upgrade
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,658
    Likes Received:
    1,425
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    As of cPanel 64, Pure-FTPD no longer supports TLS 1.0. You may want to review your FTP client's support team or documentation to verify it's not attempting to use TLS 1.0 for FTP, or try switching to ProFTPd via "WHM >> FTP Server Selection" to see if that solves the problem.

    Thank you.
     
  3. vincentg

    vincentg Well-Known Member

    Joined:
    May 12, 2004
    Messages:
    143
    Likes Received:
    3
    Trophy Points:
    168
    Location:
    new york
    Might be the case as my FTP app is a bit old.
    Clients FTP might also be old.

    Am checking with their website support.
     
  4. uk01

    uk01 Well-Known Member

    Joined:
    Dec 31, 2009
    Messages:
    72
    Likes Received:
    5
    Trophy Points:
    58
    Same issue here from customers this morning and on our own Macs. FTP only works with SSL turned off, which is not a good move in todays world.
    We use Dreamweaver CS6, as do many others in web dev. I notice in FTP SSL configs it has TLSv1, changing it to v2 does not work. Is there any other workaround as this has to work. There is no way we can force customers to move to Creative Cloud, nor can we!
     
  5. petem

    petem Member

    Joined:
    Mar 4, 2016
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    UK
    cPanel Access Level:
    Root Administrator
    I totally agree. This is going to cause us major issues. We cannot ask all our Dreamweaver users to update or use other FTP software.

    Reluctant to move to to ProFTPD as no brute force protection.
     
  6. vincentg

    vincentg Well-Known Member

    Joined:
    May 12, 2004
    Messages:
    143
    Likes Received:
    3
    Trophy Points:
    168
    Location:
    new york
    It was my FTP software as upgrading to ws_ftp 12.6 has solved the problem for me.
    But my client seems to be not so happy.

    This will cause heartache for many but it's not news to us.
    We all knew that the day TLS 1.0 was going to be dropped was coming.

    For older version Dreamweaver users best bet it to develop on local PC and use FTP to move files.
    Yes we will hear screams but such is life.
     
    Infopro likes this.
  7. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,658
    Likes Received:
    1,425
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Switching to ProFTPd via "WHM >> FTP Server Selection" would act as a workaround for customers using older FTP clients that rely on TLS 1.0. If brute force protection with ProFTPd is a concern, you may want to consider a third-party application such as CSF:

    ConfigServer Security & Firewall (csf)

    Thank you.
     
Loading...

Share This Page