The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

After upgrading to Apache 2, password protection is not working

Discussion in 'EasyApache' started by asiams, Oct 18, 2007.

  1. asiams

    asiams Well-Known Member

    Joined:
    May 28, 2003
    Messages:
    89
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Hokkaido, JAPAN
    Hello!

    After I have upgraded to Apache 2.2 with mysql 5 with Cpanel current, password protected directories are not working.

    When the site is displayed it says:

    500 Internal Error

    Here is my current setup:

    WHM 11.11.0 cPanel 11.15.0-C17700
    CENTOS Enterprise 4.5 i686 on standard - WHM X v3.1.0

    I am not using Mod suPHP. But suexec is on.

    Should I turn off suexec in order to work .htaccess properly?

    Thanks.

    asiams
     
  2. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    I would recommend you submit a support ticket regarding this issue :)
     
  3. owine

    owine Active Member

    Joined:
    Jan 10, 2007
    Messages:
    44
    Likes Received:
    0
    Trophy Points:
    6
    I had this exact issue. You need to select Auth Basic as well as Authz Group when you compile Apache. Should these be included as defaults?
     
  4. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,458
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    Good note about the Auth stuff. I'll pass it along.

    webdisk does not depend upon anything in Apache to work.
     
  5. stugster

    stugster Well-Known Member

    Joined:
    Apr 16, 2002
    Messages:
    75
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Edinburgh, UK
    cPanel Access Level:
    Root Administrator
    Just to keep this thread going, as it's still very relevant.

    I upgraded apache and PHP last night, and am now experiencing the exact same issues.

    Going back to try resolution as above and will notify the thread of the outcome.


    Cheers.
     
  6. mtindor

    mtindor Well-Known Member

    Joined:
    Sep 14, 2004
    Messages:
    1,279
    Likes Received:
    36
    Trophy Points:
    48
    Location:
    inside a catfish
    cPanel Access Level:
    Root Administrator
    Ignore what I said (that's why I deleted it rofl). I didn't read the OPs post thoroughly. I was _not_ compiling Apache 2.x, I was compiling Apache 1.3 - and in EA3 there is not even an option for Auth Basic or Auth Group. And my .htaccess files work just fine. Furthermore, I'm running R17665. So I should not have even chimed in since my configuration is not his configuration.

    Thanks for the info on webdisk though - I did have that question about DAV, but now its answered :)

    Mike
     
  7. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,458
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    Actually, I did some testing and determined:

    1. Auth Basic is de-selectable in the UI for Apache 2.2 (it is not displayed for Apache 2.0)
    2. De-selecting Auth Basic does prevent Password Protected Directories from working

    So, the thread as a whole was conducive. I've submitted a case about this for possible change. We should not allow de-selecting something that breaks a core feature :)
     
  8. asiams

    asiams Well-Known Member

    Joined:
    May 28, 2003
    Messages:
    89
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Hokkaido, JAPAN
    Problem solved

    As owine suggested, I rebuilt Apache with Auth Basic and Authz group checked. Then .htaccess was working fine.

    Thank you for all of your input on this.

    Like someone suggested, I agree that this should be checked as default in Easy Apache feature.

    asiams
     
  9. mtindor

    mtindor Well-Known Member

    Joined:
    Sep 14, 2004
    Messages:
    1,279
    Likes Received:
    36
    Trophy Points:
    48
    Location:
    inside a catfish
    cPanel Access Level:
    Root Administrator
    I just ran through a test configuration for Apache 2.2, suexec, PHP5 - and AuthzBasic was indeed checked by default.

    I agree with Kenneth that it should not be _deselectable_, but I must also say that it appears to be _active_ by default and in fact is bold blue (meaning that it's default in Apache build unless you deselect it). You probably should never deselect any of the default things that are bold blue in the config unless you know for a fact that it won't break anything.

    Mike
     
  10. asiams

    asiams Well-Known Member

    Joined:
    May 28, 2003
    Messages:
    89
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Hokkaido, JAPAN
    Somehow mine was not selected as default

    Hello Mike,

    Somehow mine was not selected as default. I upgraded Apache2.2 with all the default settings initially, then I added more features. However, Auth_Basic was not selected so were Authz features.

    I had to select them manually. Maybe my initial version of Easy Apache was different from the current one?

    Anyway, thanks for confirming this!

    asiams
     
  11. FeeL

    FeeL Well-Known Member

    Joined:
    Apr 17, 2004
    Messages:
    135
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Rio de janeiro
    cPanel Access Level:
    Reseller Owner
    how to solve?

    This is happening to mee too

    I could not quite find in the topic what would be the best procedures on this
    case.

    Do I have to re-install apache?:confused:
     
  12. mtindor

    mtindor Well-Known Member

    Joined:
    Sep 14, 2004
    Messages:
    1,279
    Likes Received:
    36
    Trophy Points:
    48
    Location:
    inside a catfish
    cPanel Access Level:
    Root Administrator
    Are you saying that you used EA3 to install Apache 2.2? If so, then yes you need to do that same exact process again, only this time make sure you checkmark the approrpiate additional options listed above (or make sure they are already checkmarked).

    Mike
     
  13. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,458
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    For Apache 2.2, we are making the Auth modules that are necessary for Password Protected Directories always enabled. The list is: AuthzDefault, AuthzUser and AuthBasic

    We will republish EA3 with this change. When your EA3 version is larger than 2662, then it should have that change.
     
  14. FeeL

    FeeL Well-Known Member

    Joined:
    Apr 17, 2004
    Messages:
    135
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Rio de janeiro
    cPanel Access Level:
    Reseller Owner
    Recompilation worked out.

    Tnx
     
Loading...

Share This Page