The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

After WHM account move, bizarre HTML rendering issue

Discussion in 'General Discussion' started by wa4fat, Aug 28, 2008.

  1. wa4fat

    wa4fat Well-Known Member

    Joined:
    Dec 30, 2001
    Messages:
    51
    Likes Received:
    1
    Trophy Points:
    8
    I recently migrated numerous account from an aging server to a new machine. The new server is running WHM 11.23.2, cPanel 11.23.4-S26138, CENTOS Enterprise 5.2 and Apache/2.0.63.

    Here's the issue -- index files don't render correctly, exhibiting really unusual behavior. As an example, here's an index.html file within a directory which shows instead a directory listing.

    http://americanvillage.org/mock/

    There is no .htaccess file in this directory, and the server-wide DirectoryIndex settings begin with :
    index.html index.shtml index.htm index.php

    The ownership appears fine, and the permissions also seem correct.

    What in the world am I overlooking ... any ideas?

    Thanks!
     
  2. MaestriaNick

    MaestriaNick Well-Known Member

    Joined:
    Aug 6, 2008
    Messages:
    159
    Likes Received:
    3
    Trophy Points:
    18
  3. wa4fat

    wa4fat Well-Known Member

    Joined:
    Dec 30, 2001
    Messages:
    51
    Likes Received:
    1
    Trophy Points:
    8
    There was a bogus mime type, which has now been removed.

    The basic problem still exists, however.

    index.html should display by default when someone accesses the http://americanvillage.org/mock/

    ... but the directory contents is displayed instead.

    Selecting the index.html file displays the file normally.

    Too weird ... any ideas?
     
Loading...

Share This Page