Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

AH01797: client denied by server configuration

Discussion in 'EasyApache' started by Abhijit Banik, Jul 5, 2016.

  1. Abhijit Banik

    Abhijit Banik Member

    Joined:
    Jun 25, 2016
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    India
    cPanel Access Level:
    Root Administrator
    I am getting following error in error log.
    Code:
        [Tue Jul 05 06:15:34.165031 2016] [access_compat:error] [pid 3276] [client 207.46.13.166:1226] AH01797: client denied by server configuration: /home/craftallure/public_html/error_log
        [Tue Jul 05 03:01:57.170880 2016] [access_compat:error] [pid 25662] [client 207.46.13.166:10635] AH01797: client denied by server configuration: /home/craftallure/public_html/error_log
        [Mon Jul 04 22:08:07.116246 2016] [cgi:error] [pid 14786] [client 82.80.249.137:62844] AH02812: attempt to invoke directory as script: /home/craftallure/public_html/cgi-bin/, referer: Index of /
        [Mon Jul 04 22:08:05.000013 2016] [access_compat:error] [pid 14788] [client 82.80.249.137:62857] AH01797: client denied by server configuration: /home/craftallure/public_html/error_log, referer: Index of /
        [Mon Jul 04 22:08:04.878630 2016] [access_compat:error] [pid 14787] [client 82.80.249.137:62845] AH01797: client denied by server configuration: /home/craftallure/public_html/error_log, referer: Index of /
    
    Where is the wrong with httpd.conf file

    Please help to solve this issue.
     
    #1 Abhijit Banik, Jul 5, 2016
    Last edited by a moderator: Jul 6, 2016
  2. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    45,478
    Likes Received:
    1,962
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello,

    Could you let us know of any custom entries to the .htaccess file within the home and public_html directories of the account referenced in that log output?

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Abhijit Banik

    Abhijit Banik Member

    Joined:
    Jun 25, 2016
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    India
    cPanel Access Level:
    Root Administrator
    After getting that trouble I uninstalled magento from cpanel. And again trying to install the same but its not installing with a popup error
    upload_2016-7-6_23-34-2.png

    Multiple trial I made but not working.

    this is apache error log

    Code:
    [Wed Jul 06 08:34:19.039299 2016] [:notice] [pid 739] ModSecurity: LIBXML compiled version="2.7.6"
    [Wed Jul 06 08:34:19.039302 2016] [:notice] [pid 739] ModSecurity: Status engine is currently disabled, enable it by set SecStatusEngine to On.
    [Wed Jul 06 08:34:19.063548 2016] [ssl:warn] [pid 740] AH01906: sxx-xx-xxx-xx.secureserver.net:443:0 server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
    [Wed Jul 06 08:34:19.067437 2016] [mpm_prefork:notice] [pid 740] AH00163: Apache/2.4.20 (cPanel) OpenSSL/1.0.1e-fips mod_bwlimited/1.4 configured -- resuming normal operations
    [Wed Jul 06 08:34:19.067456 2016] [core:notice] [pid 740] AH00094: Command line: '/usr/local/apache/bin/httpd -D SSL'
    (XID 4fsj8h) Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)
    [Wed Jul 06 10:06:29.639797 2016] [mpm_prefork:notice] [pid 740] AH00171: Graceful restart requested, doing restart
    [Wed Jul 06 10:06:29.831527 2016] [ssl:warn] [pid 740] AH01906: sxx-xx-xxx-xx.secureserver.net:443:0 server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
    [Wed Jul 06 10:06:29.849154 2016] [mpm_prefork:notice] [pid 740] AH00163: Apache/2.4.20 (cPanel) OpenSSL/1.0.1e-fips mod_bwlimited/1.4 configured -- resuming normal operations
    [Wed Jul 06 10:06:29.849167 2016] [core:notice] [pid 740] AH00094: Command line: '/usr/local/apache/bin/httpd -D SSL'
    
    
    This is CPanel Error Log

    Code:
    [Wed Jul 06 01:52:44.758139 2016] [access_compat:error] [pid 1080] [client 207.46.13.5:16272] AH01797: client denied by server configuration: /home/craftallure/public_html/error_log
    [Tue Jul 05 23:31:44.481321 2016] [access_compat:error] [pid 3900] [client 207.46.13.5:17654] AH01797: client denied by server configuration: /home/craftallure/public_html/error_log
    [Tue Jul 05 14:21:23.638728 2016] [access_compat:error] [pid 25839] [client 207.46.13.166:21800] AH01797: client denied by server configuration: /home/craftallure/public_html/error_log
    [Tue Jul 05 12:03:11.001712 2016] [access_compat:error] [pid 16290] [client 207.46.13.166:15986] AH01797: client denied by server configuration: /home/craftallure/public_html/error_log
    [Tue Jul 05 10:50:47.713697 2016] [access_compat:error] [pid 15691] [client 208.74.125.85:48050] AH01797: client denied by server configuration: /home/craftallure/public_html/error_log
    [Tue Jul 05 10:50:47.517013 2016] [access_compat:error] [pid 13292] [client 208.74.125.85:48049] AH01797: client denied by server configuration: /home/craftallure/public_html/error_log
    [Tue Jul 05 10:50:47.240269 2016] [access_compat:error] [pid 13817] [client 208.74.125.85:48048] AH01797: client denied by server configuration: /home/craftallure/public_html/error_log
    [Tue Jul 05 06:15:34.165031 2016] [access_compat:error] [pid 3276] [client 207.46.13.166:1226] AH01797: client denied by server configuration: /home/craftallure/public_html/error_log
    [Tue Jul 05 03:01:57.170880 2016] [access_compat:error] [pid 25662] [client 207.46.13.166:10635] AH01797: client denied by server configuration: /home/craftallure/public_html/error_log
    [Mon Jul 04 22:08:07.116246 2016] [cgi:error] [pid 14786] [client 82.80.249.137:62844] AH02812: attempt to invoke directory as script: /home/craftallure/public_html/cgi-bin/, referer: Index of /
    

    This in httpd.conf file information

    Code:
    # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # #
    #
    #   !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    #   DO NOT EDIT. AUTOMATICALLY GENERATED.  USE INCLUDE FILES IF YOU NEED TO MAKE A CHANGE
    #   !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    #
    #   Direct modifications to the Apache configuration file WILL be lost upon subsequent
    #   regeneration of this configuration file, or an Apache update.
    #
    #   To have your modifications retained, you should create/edit administrator-specific
    #   include files:
    #
    #       /etc/apache2/conf.d/includes/pre_main_global.conf
    #       /etc/apache2/conf.d/includes/pre_virtualhost_global.conf
    #       /etc/apache2/conf.d/includes/post_virtualhost_global.conf
    #
    # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # #
    
    ##################################################
    ##################################################
    #
    # cPanel & WHM controlled Apache configuration
    #
    ##################################################
    ##################################################
    
    Include "/etc/apache2/conf.modules.d/*.conf"
    
    # Administrator locations for safely altering httpd.conf
    Include "/etc/apache2/conf.d/includes/pre_main_global.conf"
    
    # These are hard-coded values that are required by cPanel & WHM
    PidFile /etc/apache2/run/httpd.pid
    User nobody
    Group nobody
    ExtendedStatus On
    LogLevel warn
    
    # You can change this by using WHM, and navigating to the 'Basic cPanel & WHM Setup' -> 'Contact Information' interface.
    ServerAdmin xxxxxxxxxxxxxxxx@gmail.com
    
    # You can change this by using WHM, and navigating to the 'Networking Setup' => 'Change Hostname' interface.
    ServerName sxx-xx-xxx-xx.secureserver.net
    
    # You can change this by using WHM, and navigating to the 'Apache Configuration' -> 'Global Configuration' interface.
    
    ServerSignature On
    
    
    
    <Directory "/">
        AllowOverride All
        Options All
    </Directory>
    
    
    <IfModule prefork.c>
    
    
    Please help to solve this problem
     
    #3 Abhijit Banik, Jul 6, 2016
    Last edited by a moderator: Jul 6, 2016
  4. Abhijit Banik

    Abhijit Banik Member

    Joined:
    Jun 25, 2016
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    India
    cPanel Access Level:
    Root Administrator
    There is no .htaccess file in public_html and I did not made any changes over there.
     
  5. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    45,478
    Likes Received:
    1,962
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Would you mind opening a support ticket using the link in my signature so we can take a closer look? You can post the ticket number here so we can update this thread with the outcome. You may also find the following thread helpful when opening a support ticket:

    [Informational] - Get the most from cPanel Support

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. Abhijit Banik

    Abhijit Banik Member

    Joined:
    Jun 25, 2016
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    India
    cPanel Access Level:
    Root Administrator
    I don't mind to create support ticket. Please find the support ticket number.
    Support Request ID is: 7594165
     
  7. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    45,478
    Likes Received:
    1,962
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    To update, it looks like the issue was addressed after correcting file permissions that were incompatible with suPHP.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice