The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

alias httpd error

Discussion in 'General Discussion' started by Secret Agent, Jun 2, 2005.

  1. Secret Agent

    Secret Agent Guest

    Syntax error on line 2 of /usr/local/apache/conf/httpd.conf:
    Invalid command 'Alias', perhaps mis-spelled or defined by a module not included in the server configuration
    /etc/rc.d/init.d/httpd start: httpd could not be started


    I get that when restarting apache. I removed that line, then I get this:

    Syntax error on line 213 of /usr/local/apache/conf/httpd.conf:
    Cannot load /usr/local/apache/libexec/mod_rewrite.so into server: /usr/local/apache/libexec/mod_rewrite.so: undefined symbol: dbm_fetch
    /etc/init.d/httpd startssl: httpd could not be started

    I comment that out in Load and Addon and then get this:

    Syntax error on line 214 of /usr/local/apache/conf/httpd.conf:
    API module structure `expires_module' in file /usr/local/apache/libexec/mod_expires.so is garbled - perhaps this is not an Apache module DSO?
    /etc/init.d/httpd startssl: httpd could not be started


    Seems like the error will never end.

    What to do?

    I tried:

    wget http://layer1.cpanel.net/buildapache.sea
    sh buildapache.sea

    /scripts/easyapache (#5)

    Apache logs shows nothing but typical/common "file does not exist"
     
    #1 Secret Agent, Jun 2, 2005
    Last edited by a moderator: Jun 2, 2005
  2. BianchiDude

    BianchiDude Well-Known Member
    PartnerNOC

    Joined:
    Jul 2, 2005
    Messages:
    619
    Likes Received:
    0
    Trophy Points:
    16
    I second this problem.
     
Loading...

Share This Page