The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

All accounts 403 forbidden?

Discussion in 'General Discussion' started by Final-Solution, Sep 13, 2004.

  1. Final-Solution

    Final-Solution Well-Known Member

    Joined:
    Jul 14, 2002
    Messages:
    92
    Likes Received:
    0
    Trophy Points:
    6
    I recently had to switch my IPs, so I switched them over, updated apache since WHM warned me i had some out of date stuff . . and now EVERY account I have says "forbidden"

    why would this happen?? I was trying to get it to be able to use ip/~username for some accounts, with no luck and I set everything back the way it was and still every account is not forbidden, even those on the old IPs . . any ideas?
     
  2. denisdekat09

    denisdekat09 Well-Known Member

    Joined:
    Mar 2, 2002
    Messages:
    265
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    San Francisco
    I sometimes get forbidden when directories have incorrect permissions or if they are owned by an incorrect user. You may want to check that just in case :)
     
  3. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    I would suggest that you run:

    /scripts/enablefileprotect

    Which may well correct your directory owner/permission settings which is the most likely problems as denisdekat09 pointed out.
     
  4. Final-Solution

    Final-Solution Well-Known Member

    Joined:
    Jul 14, 2002
    Messages:
    92
    Likes Received:
    0
    Trophy Points:
    6
    Thanks for the suggestions . .

    I checked the permissions and it shows the /home/username folders are all set for the appropriate username's and then I ran /scripts/enablefileprotect which said

    Setting /home permissions to 0711......Done
    Setting permissions for.....nfsnobody...iussa....etc

    But I"m still seeing the problem :/

    The full error I get when I try to check an account is

    Forbidden
    You don't have permission to access / on this server.

    Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.


    Any other suggestions? I'm at a total loss . . even accounts I didnt change the IP for are giving me the same error.
     
  5. Final-Solution

    Final-Solution Well-Known Member

    Joined:
    Jul 14, 2002
    Messages:
    92
    Likes Received:
    0
    Trophy Points:
    6
    Not sure why . . maybe when I udpated apache or cpanel . . all the public_html folders got their permissions wrong! If anyone else is having this problem chmod 755 /home/*/public_html might fix it up
     
  6. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    You didn't, by any chance, switch off or on suexec?
     
Loading...

Share This Page