Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SOLVED All e-mail going to catch-all

Discussion in 'E-mail Discussions' started by Spork Schivago, Dec 6, 2016.

  1. Spork Schivago

    Spork Schivago Well-Known Member

    Joined:
    Jan 21, 2016
    Messages:
    514
    Likes Received:
    54
    Trophy Points:
    28
    Location:
    corning, ny
    cPanel Access Level:
    Root Administrator
    Hello,

    I have my main user, sporkschivago, then I added an e-mail address in cPanel for Spork@mydomain.com. For some reason though, now I cannot send anything to SporkSchivago@mydomain.com. When I do, it ends up in the Spork@mydomain.com inbox instead.

    For example,
    I log into gmail and I create an e-mail for SporkSchivago@mydomain.com and send it. When I log into webmail, that e-mail is in the Inbox for Spork@mydomain.com instead of the SporkSchivago@mydomain.com.

    Any ideas on how to fix this? Here's a snippet of the exim_log, if that might help:
    Code:
    2016-12-07 00:06:15 1cEUQp-0002ox-5S H=mail-qk0-x234.google.com [2607:f8b0:400d:c09::234]:33566 Warning: Message has been scanned: no virus or other harmful content was found
    2016-12-07 00:06:15 1cEUQp-0002ox-5S H=mail-qk0-x234.google.com [2607:f8b0:400d:c09::234]:33566 Warning: "SpamAssassin as sporkschivago detected message as NOT spam (1.2)"
    2016-12-07 00:06:15 1cEUQp-0002ox-5S <= realemail@gmail.com H=mail-qk0-x234.google.com [2607:f8b0:400d:c09::234]:33566 P=esmtps X=TLSv1.2:ECDHE-RSA-AES128-GCM-SHA256:128 CV=no S=3955 id=CAEeNszZHzFo+vX7NGZN+YtDrWBsZAtFHNhBUVKG-b+WeurwQmg@mail.gmail.com T="another test." for SporkSchivago@mydomain.com
    2016-12-07 00:06:15 cwd=/var/spool/exim 3 args: /usr/sbin/exim -Mc 1cEUQp-0002ox-5S
    2016-12-07 00:06:15 SMTP connection from mail-qk0-x234.google.com [2607:f8b0:400d:c09::234]:33566 closed by QUIT
    2016-12-07 00:06:15 1cEUQp-0002ox-5S => spork <SporkSchivago@mydomain.com> R=virtual_user T=dovecot_virtual_delivery C="250 2.0.0 <Spork@mydomain.com> peMcJMeYR1imKQAAXjtNxg Saved"
    2016-12-07 00:06:15 1cEUQp-0002ox-5S Completed
    
    Notice the send to last entry there.
    Code:
    ...spork <SporkSchivago@mydomain.com> R=virtual_user T=dovecot_virtual_delivery C="250 2.0.0 <Spork@mydomain.com>....."
    
    It seems that's where Exim is forwarding it to Spork@mydomain.com. Where did I mess up? I must have set something that I shouldn't have set. I have no filters installed at all. I have a catch-all setup that sends all unrouted e-mails to Spork@mydomain.com, but this isn't an unrouted address that I'm sending to...

    I don't have any Forwarders set up either, but I did find this in the /etc/valiases directory:
    Code:
    root@franklin:[/etc/valiases]# cat mydomain.com 
    *: Spork@mydomain.com
    
    Is that right? Or should it be something like:
    Code:
    *: :fail: Spork@mydomain.com
    
    ?
     
    #1 Spork Schivago, Dec 6, 2016
    Last edited: Dec 6, 2016
  2. webhostuk

    webhostuk Well-Known Member

    Joined:
    Sep 11, 2013
    Messages:
    112
    Likes Received:
    11
    Trophy Points:
    18
    cPanel Access Level:
    Website Owner
    Normally when you don't set a catch all account the default Cpanel user receives all the catchall email and here it seems you default user is sporkschivago and you have set Catck all for Spork , I personally feel thats the reason email is getting forward. Just try to remove catch all for spork@mydomain account and try sending email to : sporkschivago > I feel this should solve your issue.
     
  3. Spork Schivago

    Spork Schivago Well-Known Member

    Joined:
    Jan 21, 2016
    Messages:
    514
    Likes Received:
    54
    Trophy Points:
    28
    Location:
    corning, ny
    cPanel Access Level:
    Root Administrator
    I will try removing the catch-all, I was thinking the same, but if this is the case, after rereading what the catch-all is when logged into cPanel, it seems this might be a bug.

    According to the documentation under the catch-all, this is only for e-mails that are unrouteable, not e-mails that are routeable. So far, all the e-mails I receive that are spam are to addresses that don't exist on my server. I should be able to set spork as the catch-all and not have e-mail addressed to my default account forwarded to spork. Unless of course, sporkschivago (the default account) doesn't actually have an e-mail address to begin with, and everything sent to SporkSchivago@mydomain.com really is unrouteable, but I don't think this is the case.

    If turning it off fixes it, I will file a bug report.

    I will let you know. We have to go to the doctors in a few, our daughter is sick. Thanks.
     
  4. Spork Schivago

    Spork Schivago Well-Known Member

    Joined:
    Jan 21, 2016
    Messages:
    514
    Likes Received:
    54
    Trophy Points:
    28
    Location:
    corning, ny
    cPanel Access Level:
    Root Administrator
    It did not work. I logged into cPanel and went to Home >> EMAIL >> Default Address and then clicked Advanced Options and selected:
    Code:
    Forward to your system account “sporkschivago”
    
    However, when I sent an email to SporkSchivago@mydomain.com, the e-mail, once again, arrived in the Spork@mydomain.com inbox, not the sporkschivago@mydomain.com inbox.
     
  5. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,658
    Likes Received:
    1,427
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    It doesn't exist by default. You need to create an email account for $account-username@domain.com if you'd like to use it as a separate email account.

    Thank you.
     
    Spork Schivago likes this.
  6. Spork Schivago

    Spork Schivago Well-Known Member

    Joined:
    Jan 21, 2016
    Messages:
    514
    Likes Received:
    54
    Trophy Points:
    28
    Location:
    corning, ny
    cPanel Access Level:
    Root Administrator
    Is the default account setup as a catch-all by default? Because I was receiving e-mails for it just fine until recently. I'd say around the time I made Spork the catch-all, that's when SporkSchivago@mydomain.com didn't receive anymore e-mails.

    It seems you figured this out for me and I appreciate your help once again cPanelMichael. When I log in through webmail, now do I need to add the @mydomain.com for the SporkSchivago or can I continue to log in with just SporkSchivago, like I have been doing?

    The catch-all is working as expected, the SporkSchivago@mydomain.com is working as expected and the Spork@mydomain.com is working as expected. Thank you.
     
  7. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    15,769
    Likes Received:
    313
    Trophy Points:
    433
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Yes. The full email is the username for that email account.
     
    Spork Schivago likes this.
  8. Spork Schivago

    Spork Schivago Well-Known Member

    Joined:
    Jan 21, 2016
    Messages:
    514
    Likes Received:
    54
    Trophy Points:
    28
    Location:
    corning, ny
    cPanel Access Level:
    Root Administrator
    I gotcha, so in webmail,
    SporkSchivago
    and
    SporkSchivago@mydomain.com

    are two different accounts and if emails are sent to SporkSchivago@mydomain.com, they won't show up under SporkSchivago.

    Thank you.
     
  9. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    15,769
    Likes Received:
    313
    Trophy Points:
    433
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Yes, almost. Your cPanel user, the name used to login to your cPanel with, does not have an actual email account. Logging into webmail as that cPanel user, you're logging into that cPanel account's system "mailbox" which is not an actual email account.

    To use that cPanel user's name for an email account you have to create an email account using it (the same name).

    Under normal circumstances, the cPanel user system account should never get any email. Unrouted email to @domain.com (me@, him@, her@) should be set to fail, not forward to a valid account.
     
    Spork Schivago likes this.
  10. Spork Schivago

    Spork Schivago Well-Known Member

    Joined:
    Jan 21, 2016
    Messages:
    514
    Likes Received:
    54
    Trophy Points:
    28
    Location:
    corning, ny
    cPanel Access Level:
    Root Administrator
    I gotcha, but why should it normally fail, out of curiosity? It's just because it's more than likely spam, right?

    In my case, my domain was once associated with something, a long time ago. There are websites that give an e-mail address to someone at my domain. I want those e-mails for one reason or another. I'm not doing anything shady with them, nothing like that. Just trying to bring something back to life that died out a long time ago.
     
  11. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    15,769
    Likes Received:
    313
    Trophy Points:
    433
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    It's not an email account. Here's an old blog post by ConfigServer about why you should use fail:
    Why you should use :fail:

    Creating an actual email account to capture those might be best.
     
    Spork Schivago likes this.
  12. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,658
    Likes Received:
    1,427
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    You can also configure the default forwarding destination for a new account’s catch-all/default address under the "Mail" tab in "WHM >> Tweak Settings" with this option:

    Initial default/catch-all forwarder destination

    It's set to "System account" by default.

    Thank you.
     
    Spork Schivago likes this.
  13. Spork Schivago

    Spork Schivago Well-Known Member

    Joined:
    Jan 21, 2016
    Messages:
    514
    Likes Received:
    54
    Trophy Points:
    28
    Location:
    corning, ny
    cPanel Access Level:
    Root Administrator
    The bandwidth reason seems like a really good reason for me, seeing how I don't have "unlimited" bandwidth anymore. I couldn't imagine the e-mails eating up a lot of bandwidth, but why waste unnecessary bandwidth, right?

    I'll heed your advice, create the email accounts that I'm awaiting emails on and configure the unrouteable ones to fail. Thank you for taking the time to explain all of this to me. For some reason, I couldn't think of any other reasons besides spam. Your link makes very valid points and for this, I thank you.

    Thanks!
     
    Infopro and cPanelMichael like this.
  14. Spork Schivago

    Spork Schivago Well-Known Member

    Joined:
    Jan 21, 2016
    Messages:
    514
    Likes Received:
    54
    Trophy Points:
    28
    Location:
    corning, ny
    cPanel Access Level:
    Root Administrator
    Oh, cool! So instead of just selecting it in cPanel, I can set it up for all domains that are created and have a system-wide default forwarder, nice.

    I was reading the link that Infopro sent me. If I set it to forward the unrouteable emails to an external account, such as my gmail account, for example, would the email still be fully processed by my server? Would it still be equivalent, resource wise, as just forwarding it to an account on my server?
     
  15. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,658
    Likes Received:
    1,427
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    This option controls how the "Default Address" option in cPanel is configured on new accounts and new addon domains/aliases. It won't change the default configuration for existing accounts, or forward all unrouted emails to a global system address.

    Yes, it acts how a forwarder would. However, I'd advise against setting it to an external address such as Google. The messages sent to email accounts that don't exist are often SPAM, and thus you'd have SPAM forwarded to Google which could put your server on a blacklist.

    Thanks!
     
    Spork Schivago likes this.
  16. Spork Schivago

    Spork Schivago Well-Known Member

    Joined:
    Jan 21, 2016
    Messages:
    514
    Likes Received:
    54
    Trophy Points:
    28
    Location:
    corning, ny
    cPanel Access Level:
    Root Administrator
    That's a good point. I'm not going to do it anyway, I just wanted a better understanding of how it worked. Thanks for taking the time to explain this to me.
     
  17. Spork Schivago

    Spork Schivago Well-Known Member

    Joined:
    Jan 21, 2016
    Messages:
    514
    Likes Received:
    54
    Trophy Points:
    28
    Location:
    corning, ny
    cPanel Access Level:
    Root Administrator
    Now that this is solved and the problem is fixed, how do I go about changing the thread from In Progress to solved?
     
  18. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    15,769
    Likes Received:
    313
    Trophy Points:
    433
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    You can't from there. But its now been marked as such. :)
     
    Spork Schivago likes this.
  19. Spork Schivago

    Spork Schivago Well-Known Member

    Joined:
    Jan 21, 2016
    Messages:
    514
    Likes Received:
    54
    Trophy Points:
    28
    Location:
    corning, ny
    cPanel Access Level:
    Root Administrator
    Thanks! It'd be nice if the cPanel forums had one of those Mark as Solution buttons, so in long threads that go on for pages and pages, when someone's looking for answers to a question, they can just click something like See accepted solution, instead of reading the entire thread.
     
    Infopro likes this.
  20. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    15,769
    Likes Received:
    313
    Trophy Points:
    433
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Agreed. I'm sure we can come up with something along those lines. Stay tuned. :)

    Thanks for your feedback.
     
    Spork Schivago likes this.
Loading...

Share This Page