All emails except those from CPanel itself are getting Frozen in Mail Queue Manager

wesman

Registered
Apr 24, 2020
2
1
3
Australia
cPanel Access Level
Root Administrator
Hi

Running WHM on a VPS. Mail from websites and JetBackup were working fine until at least 5:10pm yesterday evening (when we received a Jetbackup job confirmation email) but for the 11:10pm run of that same job no email was sent and checking the server's Mail Queue Manager today it shows tens of emails in all, all marked as Frozen. Viewing the error/descriptive message for each email it shows "Domain of sender address [email protected] does not exist"

We are not sure where this SAU-xxxx-VS value is set, why it is being used and why or what changed since emails were being sent from the server yesterday. Currently all websites running on the server are unable to send emails, and JEtbackup emails are also just getting stuck in the Mail Queue. This is very frustrating that something is working one moment and then just stops working with serious consequences like all websites having their emails not being sent.

Hoping someone can advise a solution here. We have reached out to the tech support people at our server provider but it is Friday night here and no one has replied yet.

Thanks
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,296
1,252
313
Houston
As far as I know with JetBackup the email notifications are configured in the settings as noted here: Notification — JetBackup Documentation documentation

Why is other mail unable to be sent? What's noted in the exim logs? You can find them at /var/log/exim_mainlog
 

wesman

Registered
Apr 24, 2020
2
1
3
Australia
cPanel Access Level
Root Administrator
I found out - myself - that the hostname for the server had changed from a FQDN to a shortened version missing the top level domain part of the name. Not sure why that happened or how but I fixed the mail problem by running the whmapi1 sethostname hostname command at the SSH command line.
 
  • Like
Reactions: cPanelLauren