All incoming emails arrive with a delay of several minutes

Operating System & Version
CentOS 7
cPanel & WHM Version
v94.0.3

hanphi

Registered
Mar 21, 2021
3
0
1
LH
cPanel Access Level
Reseller Owner
Hello,
I just bought 2 servers with Cpanel and I have the same problem on both.

Any email sent to the domains on these servers arrive with a delay of 10 minutes to 1 hour without explanation.

My greylisting is disabled and when I monitor /var/log/maillog
with the command :

tail -f /var/log/maillog | egrep "[email protected]" --color

nothing appears in the file until the email finally arrives.

It looks like the email takes several minutes to go around the world to finally find the server


Could someone help me ?
 
Last edited by a moderator:

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
7,491
1,008
313
cPanel Access Level
Root Administrator
Hey there! In WHM >> Exim Configuration Manager, do you have the "Introduce a delay into the SMTP transaction for unknown hosts and messages detected as spam" option enabled? If so, that would contribute to the delay as it makes the sender re-send the message to help fight automated spam.
 

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
7,491
1,008
313
cPanel Access Level
Root Administrator
Thanks for checking that. Do you know where the delay is? By that, I mean is the delay with the email getting to your cPanel machine, or once the server has the message there is a delay in it being delivered? If it's the first situation, there may not be much you can do with that, but you could always check your DNS using a tool like intoDNS: checks DNS and mail servers health to see if there is any odd behavior there. If it's the second situation, I would expect the Exim log at /var/log/exim_mainlog to show why it is taking some time to handle the messages.
 

hanphi

Registered
Mar 21, 2021
3
0
1
LH
cPanel Access Level
Reseller Owner
cPRex,

Thank you for you help

I file /var/log/exim_mainlog

I found information about a problem this ONLY (for the moment) my provider

2021-03-24 00:15:05 TLS error on connection from (smtp.smtpout.orange.fr) [80.12.242.124]:49072 (SSL_accept (TLSv1.2)): error:140760FC:SSL routines:SSL23_GET_CLIENT_HELLO:unknown protocol
2021-03-24 00:17:50 SMTP command timeout on connection from (smtp.smtpout.orange.fr) [80.12.242.124]:49072


But to be honnest, I don't understand what is the problem :/
 

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
7,491
1,008
313
cPanel Access Level
Root Administrator
Thanks for those details. That sounds like it would be a different issue from the delay you mentioned earlier. Do you have any information about the client that is trying to connect? It seems like that client used a protocol that is older and no longer accepted by the server.
 

lernierd

Member
Jun 6, 2019
5
2
3
Veracruz, México
cPanel Access Level
Root Administrator
Hi,
I have the same problem with two different servers, both on CentOS 7.9 and Ver. 94.0 .
Checking the Mail Delivery reports I can see that almost 100% of the delayed emails are delivered minutes later, but before that an email with the Error "451 Temporary local problem - please try later" es return to the sender.

Thanks,
 

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
7,491
1,008
313
cPanel Access Level
Root Administrator
There seem to be a few different issues mentioned here, as the original poster was talking about incoming messages. @lernierd - it sounds like you are talking about sending messages.

If you restart Exim on your server, does that also get things working well for a period of time?