The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

All pops not visible after transfer

Discussion in 'General Discussion' started by Arsalan, Sep 21, 2004.

  1. Arsalan

    Arsalan Well-Known Member

    Joined:
    Jan 5, 2002
    Messages:
    51
    Likes Received:
    0
    Trophy Points:
    6
    All of the pop3 accounts on our server are not visible via cpanel (pops.html) after we moved them the account from one server to another..

    Any old else had this problem ever before?

    Any way to solve it?
     
  2. Arsalan

    Arsalan Well-Known Member

    Joined:
    Jan 5, 2002
    Messages:
    51
    Likes Received:
    0
    Trophy Points:
    6
    apparently the "passwd" file in /home/USERNAME/etc/ only have one entry and this is where cpanel picks up the pop3 accounts from...
     
  3. Arsalan

    Arsalan Well-Known Member

    Joined:
    Jan 5, 2002
    Messages:
    51
    Likes Received:
    0
    Trophy Points:
    6
    I just saw that this customers account is overquota as well. Could this have been caused due to this?
     
  4. Arsalan

    Arsalan Well-Known Member

    Joined:
    Jan 5, 2002
    Messages:
    51
    Likes Received:
    0
    Trophy Points:
    6
    I solved this issue, by copying all of the usernames over from "passwd,v" to the damaged "passwd" file, and chancing their ids according to the new server.

    i.e.

    passwd,v had

    emailUSER:x:32035:32035::/home/USERNAME/mail/domain.com/emailUSER:/usr/local/cpanel/bin/noshell

    but accounts are created on the new server in the passwd file with

    emailUSER:x:30025:30025::/home/USERNAME/mail/domain.com/emailUSER:/usr/local/cpanel/bin/noshell

    so i got the complete list from "passwd,v" and changed their ids and wola, pop3's were visible and accessible via horde.
     
    #4 Arsalan, Sep 21, 2004
    Last edited: Sep 21, 2004
Loading...

Share This Page