The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

All Releases Broke!

Discussion in 'General Discussion' started by webolocity, Mar 11, 2004.

  1. webolocity

    webolocity Well-Known Member

    Joined:
    Jul 22, 2003
    Messages:
    78
    Likes Received:
    0
    Trophy Points:
    6
    I did an upgrade earlier to Edge, and the new cpservd was broke and no access to Cpanel.

    So, I downgraded to Current and the same thing. I than , downgraded to Stable which fixed Cpanel.

    Now later this evening there a message about a security hole, well the link to disable doesn't do anything, so I tried to upgrade to Current to see if it fixed things now, but than broke Cpanel.

    Than, again upgraded to Edge. Cpanel still broke. Tried to downgrade to Release version, cpanel still broke.

    Tried to again, downgrade to Stable on 4 attempts but, get an error,
    Unable to Fetch the file.

    Nothing now works for Cpanel. Cannot even login. I have opened a support Ticket. Please fix at least one verison ASAP!

    Thanks!

    P.S. Here is the error when trying to go to Stable:

    Fetching http://httpupdate.cpanel.net/cpanelsync/STABLE/install....Error 404 while fetching url http://httpupdate.cpanel.net//cpanelsync/STABLE/install
     
  2. inogenius

    inogenius Well-Known Member

    Joined:
    Apr 16, 2003
    Messages:
    45
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Cleveland, Ohio
    cPanel Access Level:
    DataCenter Provider
    Reboot your server. You may also have to restart cppop once it has come back up. I noticed it had failed on my machine when it restarted.
     
  3. webolocity

    webolocity Well-Known Member

    Joined:
    Jul 22, 2003
    Messages:
    78
    Likes Received:
    0
    Trophy Points:
    6
    Reboot server

    We actually had to reboot the server earlier because of this. I prefer at this point for Cpanel to provide a good release to fix this.

    I already had angry customers this morning when they could not get mail etc...

    thanks.
     
  4. webolocity

    webolocity Well-Known Member

    Joined:
    Jul 22, 2003
    Messages:
    78
    Likes Received:
    0
    Trophy Points:
    6
    New Release Version Fixed

    Relaease version: WHM 9.0.0 cPanel 9.0.0-R44 , fixed it.

    A little while ago, we tried release and it also did not work. But, we ran again and this time is fixed.

    FYI for anyone who may have experienced this.
     
  5. verdon

    verdon Well-Known Member

    Joined:
    Nov 1, 2003
    Messages:
    836
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Northern Ontario, Canada
    cPanel Access Level:
    Root Administrator
    I did the initial disabling of allowing users to changes passwords via email, as suggested yesterday. Had no problems there.

    This morning I have a new message in my news advising to upgrade to 'new build (9.1.0 build 49 or later) which has a proper fix'. I'd like to do that, but am concerned that if I do, I'll have to start dealing with the new DNS stuff being discussed in this thread...

    http://forums.cpanel.net/showthread.php?s=&threadid=20609

    My ignorance may just be confusing stable with edge releases and stuff. Does anyone have any advice to offer?

    Currently I have...

    WHM 8.8.0 cPanel 8.8.0-R10__
    RedHat 8.0 - WHM X v2.1.2

    ...running pretty well. I'd like to stay secure but sure don't want to get into a dns mess, possibly causing issues with my host host who is providing secondary dns for me.

    Do I have to worry about the new dns management model if I do the upgrade that whm news is recommending?

    Thanks,
    :)
     
  6. Mani

    Mani Well-Known Member

    Joined:
    Dec 22, 2003
    Messages:
    117
    Likes Received:
    0
    Trophy Points:
    16
    stable is out there.

    you can just stop your fire wall and update went smooth here so far on 6 box's
     
  7. webolocity

    webolocity Well-Known Member

    Joined:
    Jul 22, 2003
    Messages:
    78
    Likes Received:
    0
    Trophy Points:
    6
    RE: R-49

    Your probably okay, since R-44 got everything working except the password reset, which we disabled as well.

    If you run into any problem with the cpservd not starting, we run a restart of cpanel from shell yesterday (after the R-44 downgrade), and everything started. (service cpanel restart).

    Hope this helps.
     
  8. Tom Pyles

    Tom Pyles Well-Known Member

    Joined:
    Apr 26, 2002
    Messages:
    254
    Likes Received:
    0
    Trophy Points:
    16
    Ok...upgraded all of our servers, but one is throwing a fit. Cannot get WHM to restart. Server is up and running and it appears all services except for WHM are running. Rebooted the server...did not work. Also manually restarted services and that didn't work.

    Any suggestions?
     
  9. XPerties

    XPerties Well-Known Member

    Joined:
    Apr 10, 2003
    Messages:
    401
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    New Jersey, USA
    Now Im stuck with whm and cpanel down and waiting on reply from cpanel techs.

    cPanel.net Support Ticket Number: 42759
     
  10. Tom Pyles

    Tom Pyles Well-Known Member

    Joined:
    Apr 26, 2002
    Messages:
    254
    Likes Received:
    0
    Trophy Points:
    16
    Basically the same situation as us:

    Stopping cPanel services: [ OK ]
    Stopping webmail services: [ OK ]
    Stopping pop3 services: [ OK ]
    Stopping cPanel log services: [ OK ]
    Stopping cPanel Chat services: [FAILED]
    Stopping Melange Chat services: [FAILED]
    Stopping InterChange services: [FAILED]
    Stopping cPanel ssl services: [ OK ]
    Stopping Web Host Manager services: [ OK ]

    Stopping mailman services: Shutting down Mailman's master qrunner
    No child with pid: 10472
    [Errno 3] No such process
    Stale pid file removed.

    Starting eximstats: [ OK ]
    Starting cPanel services: [ OK ]
    Starting WebMail services: [FAILED]
    Starting pop3 services: [ OK ]
    Starting cPanel Chat services:
    Starting Melange Chat services:
    Starting cPanel ssl services: [ OK ]
    Starting Web Host Manager services: [FAILED]
     
  11. SkyfireMike

    SkyfireMike Member

    Joined:
    Aug 7, 2003
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    I just upgraded to 9.10-R72, and I've got a number of pages that are not loading whatsoever.

    ANYTHING linking to scripts2 is totally broken and not loading, as if the scripts2 directory is gone.

    HELP! My WHM is COMPLETELY broken at this point!!!

    Mike
     
  12. greengiant

    greengiant Well-Known Member

    Joined:
    Aug 31, 2003
    Messages:
    48
    Likes Received:
    0
    Trophy Points:
    6
    This fixed our server here.

    rm -f /usr/local/cpanel/cpanel
    /scripts/installgd
    /scripts/cleanmd5
    /scripts/upcp
     
  13. XPerties

    XPerties Well-Known Member

    Joined:
    Apr 10, 2003
    Messages:
    401
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    New Jersey, USA
    I did that 6 times.

    Finally it went through without failing and fetching all files.

    All good here.
     
  14. SkyfireMike

    SkyfireMike Member

    Joined:
    Aug 7, 2003
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    It worked for me too! THANKS!

    Mike
     
  15. Tom Pyles

    Tom Pyles Well-Known Member

    Joined:
    Apr 26, 2002
    Messages:
    254
    Likes Received:
    0
    Trophy Points:
    16
    LOL...same here. Ran the same scripts earlier and continued to fail. Ours worked about the same time the other users here.....Seems all good for now :)
     
  16. ahwheelock

    ahwheelock Well-Known Member

    Joined:
    Nov 5, 2001
    Messages:
    49
    Likes Received:
    0
    Trophy Points:
    6
    Thanks for saving our butts. That works...this thread should be made more obvious for all the people visiting the forums today to resolve this issue.
     
  17. woolly

    woolly Active Member

    Joined:
    Dec 29, 2003
    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    1
    still not working for me :(

    using Redhat 9.
    I can't even connect to cpanel.
     
  18. xjeffx

    xjeffx Registered

    Joined:
    May 5, 2002
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    The above seemed to work for me. But when I attempt to restart Cpanel I get this:

    Stopping cPanel services: [ OK ]
    Stopping pop3 services: [ OK ]
    Stopping cPanel log services: [ OK ]
    Stopping cPanel Chat services: [ OK ]
    Stopping Melange Chat services: [ OK ]
    Stopping InterChange services: [FAILED]
    Stopping cPanel ssl services: [ OK ]

    Stopping mailman services: Shutting down Mailman's master qrunner
    PID unreadable in: /usr/local/cpanel/3rdparty/mailman/data/master-qrunner.pid
    [Errno 2] No such file or directory: '/usr/local/cpanel/3rdparty/mailman/data/master-qrunner.pid'
    Is qrunner even running?

    Starting eximstats: DBI connect('eximstats:localhost','eximstats',...) failed: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2) at /usr/local/cpanel/bin/eximstats line 258
    Can't Connect at /usr/local/cpanel/bin/eximstats line 261.
    [FAILED]
    Starting cPanel services: [ OK ]
    Starting cPanel Log services: [ OK ]
    Starting pop3 services: [ OK ]
    Starting cPanel Chat services: [ OK ]
    Starting Melange Chat services: [ OK ]
    Starting cPanel ssl services: [ OK ]
    Starting mailman services: Site list is missing: mailman


    I tried to restart mysql and get this error:

    root@vps [/etc/init.d]# /etc/init.d/mysql restart
    No mysqld pid file found. Looked for /var/lib/mysql/vps.xedgehosting.com.pid.


    Any ideas?

    I've updated, I'm running 9.1 r-72

    TIA
     
  19. Lippy

    Lippy Active Member

    Joined:
    Jan 9, 2003
    Messages:
    40
    Likes Received:
    0
    Trophy Points:
    6
    Will removing that file cause anything but Cpanel not to work? Not that Cpanel is working anyways.

    Please advise, thank you.
     
  20. greengiant

    greengiant Well-Known Member

    Joined:
    Aug 31, 2003
    Messages:
    48
    Likes Received:
    0
    Trophy Points:
    6
    No everything else stays running, just WHM CPANEL, dies.. to the best of my knowledge
     
Loading...

Share This Page