The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

All subdomain point to folder public_html (wrong)

Discussion in 'General Discussion' started by Paolo Tateo, Jun 8, 2015.

  1. Paolo Tateo

    Paolo Tateo Registered

    Joined:
    May 19, 2015
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Torino
    cPanel Access Level:
    Root Administrator
    I do not understand how it happened, do not you remember my last action before this error, but now there is this:

    I have configured the subdomain pippo.mydomain.com that point in the Document Root /pippo BUT really point to /public_html

    In the Subdomains section It seems to set everything right (I manage 8 server with WHM, and I've never seen behavior like this). 10 minutes before working properly. What could have happened?
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,811
    Likes Received:
    667
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello,

    Try rebuilding the Apache configuration file via:

    Code:
    /scripts/rebuildhttpdconf
    Does the issue continue? Are the document root values configured incorrectly in the files within the /var/cpanel/userdata/$username/ directory?

    Thank you.
     
    Paolo Tateo likes this.
  3. Paolo Tateo

    Paolo Tateo Registered

    Joined:
    May 19, 2015
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Torino
    cPanel Access Level:
    Root Administrator
    It works, thanks!
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,811
    Likes Received:
    667
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
Loading...

Share This Page