murugan

Member
Mar 23, 2004
18
0
151
Hi all,

Today i updated apache build and the whm/cpanel to latest release tree.

After few mins i found that none of the sites are working. What ever the website we try to visit it showing the default one (visit www.kollywoodcinema.com, www.sowkartextiles.com )

Then i logged in using Putty and found all the contents are there in the HDD safely on their accounts, but the site is not working.

Anyone Please help to sort out this .
 

dandanfireman

Well-Known Member
PartnerNOC
May 31, 2002
117
0
316
Sounds like maybe your httpd.conf file got fried. You might check it and see if all the virtual host sections for your accounts are there.
 

OCX

Well-Known Member
Sep 20, 2003
231
0
166
login to WHM

click on "Configuration file rollback"

Click on /usr/local/apache/conf/httpd.conf button

then roll back to the last good conf..just click the rollback once
then scroll down and see if the domains are listing in there.

if not..roll back again..till you see it..



then restart apache..
and you SHOULD be back up and running)
 

compunet2

Well-Known Member
Feb 21, 2003
309
0
166
What happens when you do
apache stop
apache start

What error messages do you get?
 

murugan

Member
Mar 23, 2004
18
0
151
Apache restart fails....

OCX said:
login to WHM

click on "Configuration file rollback"

Click on /usr/local/apache/conf/httpd.conf button

then roll back to the last good conf..just click the rollback once
then scroll down and see if the domains are listing in there.

if not..roll back again..till you see it..



then restart apache..
and you SHOULD be back up and running)

When i tried to restart Apache from WHM its saying restart httpd failed. Contact admin.


How to solve this.
 

compunet2

Well-Known Member
Feb 21, 2003
309
0
166
Connect to SSH, type
apache stop

then type:
apache start

What does is say? If it continues giving an error, try running /scripts/easyapache again, and choose option 1.
 

compunet2

Well-Known Member
Feb 21, 2003
309
0
166
Option 1 is the basic apache install (no php, cgi, etc.). At least now we know your httpd.conf is ok. Try one of the more advanced options that installs php, cgi, etc. Everything except for the expert config should be pretty safe to use. If you use the expert config, just be aware that some of the options listed dont play well together, so selecting the wrong combination will break everything again.