The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

"Allow DKIM Verification" is blocking valid DKIM?

Discussion in 'E-mail Discussions' started by nusuni, May 23, 2014.

  1. nusuni

    nusuni Registered

    Joined:
    May 23, 2014
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hey guys,

    Been trying to fix up and customize my exim config. The server is a fresh whm install, with very little default changes.

    Whenever I enable "Allow DKIM verification for incoming messages" It will reject email from nearly any server, even if the DKIM entries are valid. "Reject DKIM failures" doesn't make a difference either way.

    Example log entry, the email is from a gmail account:

    2014-05-23 19:36:06 1WnvGA-0000tp-ME H=mail-qg0-f51.google.com [209.85.192.51]:52864 rejected DKIM

    The port 25 verifier service all says the DKIM is valid and "passed" from various domains that were rejected (gmail, yahoo, and my own). So I know the entries are valid.... the issue is definitely on my setup.

    For kicks - I also enabled the option on another WHM server and... same issue. Tried adjusting the server's resolver in case it had a wonky DNS config and - same issue still.

    Anyone have any clue why this may be happening? I'm stumped.
     
  2. nusuni

    nusuni Registered

    Joined:
    May 23, 2014
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
  3. TraderStf

    TraderStf Member

    Joined:
    Feb 27, 2014
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Belgium
    cPanel Access Level:
    Root Administrator
    I think it is because lot of sites don't care of setting a good DKIM.
    I had the same problem, too many emails rejected, specially those from autoreply, subscription... automatic ones.

    Checking SPF is enough...

    Similar problem with "Sender Verification Callouts", even worse... keep it off.
    Just switch on the one below "Sender Verification" (without callouts).

    Hope this help.
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,830
    Likes Received:
    672
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Could you elaborate on the specific entry you found and what steps you took to resolve the issue? Are you referring to the "acl_smtp_dkim = acl_smtp_dkim" entry?

    Thank you.
     
  5. nusuni

    nusuni Registered

    Joined:
    May 23, 2014
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Yep, it had a random acl_smtp_dkim = acl_smtp_dkim entry

    Manually removed it from the configuration, and everything has worked fine since with DKIM verification enabled. WHM version used was 11.42.1 (build 16). No idea how it got there - since like I said before - this was a brand new server. Seems to be fine now though.
     
  6. superduper

    superduper Registered

    Joined:
    Jul 14, 2014
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hello!

    Before enabling "Allow DKIM verification for incoming messages" I checked my EXIM configuration and I had no value on "acl_smtp_dkim".
    After enabled, "acl_smtp_dkim" had a value of "acl_smtp_dkim".
    Is that correct? Or should I remove it?

    Thank you
     
  7. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,830
    Likes Received:
    672
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Could you elaborate on the change in your /etc/exim.conf file? For instance, you can post the difference in output from:

    Code:
    grep acl_smtp_dkim /etc/exim.conf
    Thank you.
     
Loading...

Share This Page