Allow incoming mail from one source/exclude all others

unco

Active Member
Jun 17, 2010
35
6
58
Southern Pines, NC
Hi -

This may be more simple than I'm making it out to be, but here's what's happening:

1. We use SpamExperts for incoming email.
2. We are still getting spam that is bypassing SpamExperts somehow and being delivered straight to the account on the server.
3. SpamAssassin is turned off, due to more false positives.

I've tried blocking at the server level in Exim, for subject lines such as Levitra, Viagra, etc. It's not helping.

I'd like to know if I can only allow inbound mail from the SpamExperts IP addresses, and that won't interfere with customers sending mail on ports 25, etc.

Thanks,
Beth
 
Last edited by a moderator:

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
7,519
1,027
313
cPanel Access Level
Root Administrator
Hey there! Since you don't want to disrupt other users that may be connecting with mail clients, I'm not sure if there is an easy way around this. This sounds like something that might be customizable in Exim, but I didn't find any obvious answer while reviewing their documentation.

There is the WHM >> Exim Configuration Manager >> Access Lists tool, which allows country blocking and blacklisting IP addresses from Exim completely, but I'm not sure if this robust enough for your needs.
 

keat63

Well-Known Member
Nov 20, 2014
1,916
263
113
cPanel Access Level
Root Administrator
@unco By the sounds of your initial description, I'm assuming that you are a root user?
Have you considered adding any custom RBL's to your exim config.

SpamCop and SpamHaus may be disabled by default. Enable those two for a start.

Also see attached a list of the custom ones I use, these might help.
I honestly can't remember the last time I saw an email for Viagra.
 

Attachments

  • Like
Reactions: cPRex