Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

allow_url_fopen: Google Maps API - Bad coding or Difficult host?

Discussion in 'Security' started by Colink2, Apr 8, 2017.

  1. Colink2

    Colink2 Registered

    Joined:
    Apr 8, 2017
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    UK
    cPanel Access Level:
    Website Owner
    I have limited coding skills, even less cPanel skills. I am stuck between a developer and web host.

    I am keen to know if my developer needs to be using different coding or my web host has unreasonable security protocols in place,

    My developer requires at least 2 of the following features enabled - allow_url_fopen, allow_url_include or ini_set (not sure which 2).

    php.ino has the following settings
    allow_url_fopen = On
    allow_url_include = On

    His code for connecting to Google Maps API worked fine until my Web Host moved me to a newer server, now one page is being blocked and web host is inflexible. This page sends an address to google via the Maps API, to return Lat, Lng values.

    I have copied the code to another web host and all is back to what it was.

    Web original web host blames developer, developer blames web host. Should the developer be using different code that does not require allow_url_fopen, allow_url_include or ini_set?

    Old server: Centros 6.9, New server Centros 7.1 Both using PHP 5.6 and MySQL 5.6.35
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,658
    Likes Received:
    1,419
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
Loading...

Share This Page