allow_url_fopen on LiteSpeed not enabling?

inteldigital

Well-Known Member
Apr 5, 2018
87
15
8
England
cPanel Access Level
Root Administrator
Twitter
Hi guys,

Done a quick search but couldn't find anything specifically relating to my problem. I know it's probably something trivial, but I'm fairly new to LiteSpeed and can't figure out why allow_url_fopen is coming back as disabled even though I've enabled it within Multi-PHP for my domain. I'm running CentOS 7 with LiteSpeed (obviously)but no CloudLinux.

Any help appreciated.

Also, there appears to be a missing handler in LiteSpeed for PHP 7.3, is this normal?

Screenshot 2020-02-26 at 14.23.07.png

Thanks
 
Last edited:

cPanelLauren

Technical Support Community Manager
Staff member
Nov 14, 2017
13,304
1,249
313
Houston
Hello,


Is the setting enabled in the PHP INI for the PHP version you're using in WHM? IF this is disabled in WHM for that version of PHP your changes within cPanel won't make any difference as the php.ini file there is global for that PHP version. You can usually see this with a phpinfo page

Do you have PHP 7.3 installed on the server? rpm -qa |grep ea-php73
 

inteldigital

Well-Known Member
Apr 5, 2018
87
15
8
England
cPanel Access Level
Root Administrator
Twitter
Hey @cPanelLauren, thanks for responding so timely.


ea-php73-php-litespeed-7.3.14-1.1.1.cpanel.x86_64
ea-php73-php-soap-7.3.14-1.1.1.cpanel.x86_64
ea-php73-php-devel-7.3.14-1.1.1.cpanel.x86_64
ea-php73-php-ioncube10-10.3.9-1.1.10.cpanel.x86_64
ea-php73-7.3.14-1.1.1.cpanel.x86_64
ea-php73-php-bcmath-7.3.14-1.1.1.cpanel.x86_64
ea-php73-php-iconv-7.3.14-1.1.1.cpanel.x86_64
ea-php73-php-ftp-7.3.14-1.1.1.cpanel.x86_64
ea-php73-php-pdo-7.3.14-1.1.1.cpanel.x86_64
ea-php73-php-zip-7.3.14-1.1.1.cpanel.x86_64
ea-php73-php-xmlrpc-7.3.14-1.1.1.cpanel.x86_64
ea-php73-php-cli-7.3.14-1.1.1.cpanel.x86_64
ea-php73-libc-client-2007f-17.17.1.cpanel.x86_64
ea-php73-php-sockets-7.3.14-1.1.1.cpanel.x86_64
ea-php73-php-imap-7.3.14-1.1.1.cpanel.x86_64
ea-php73-php-posix-7.3.14-1.1.1.cpanel.x86_64
ea-php73-pear-1.10.7-1.4.27.cpanel.noarch
ea-php73-php-gd-7.3.14-1.1.1.cpanel.x86_64
ea-php73-php-calendar-7.3.14-1.1.1.cpanel.x86_64
ea-php73-php-fpm-7.3.14-1.1.1.cpanel.x86_64
ea-php73-php-xml-7.3.14-1.1.1.cpanel.x86_64
ea-php73-php-mysqlnd-7.3.14-1.1.1.cpanel.x86_64
ea-php73-php-common-7.3.14-1.1.1.cpanel.x86_64
ea-php73-php-curl-7.3.14-1.1.1.cpanel.x86_64
ea-php73-runtime-7.3.14-1.1.1.cpanel.x86_64
ea-php73-php-mbstring-7.3.14-1.1.1.cpanel.x86_64


Indeed I do? PHP 7.3 is set as the default PHP version in WHM. I had allow_url_fopen turned off in MultiPHP INI in WHM, I have turned it on now but still not seeing it enabled within, say, WordPress applications.
 

cPanelLauren

Technical Support Community Manager
Staff member
Nov 14, 2017
13,304
1,249
313
Houston
allow_url_fopen It's enabled in the php.ini after that change - do you have anything in the .htaccess?

You definitely have php7.3 installed - is it set as the PHP handler for that version of PHP in MultiPHP manager within WHM?
 

inteldigital

Well-Known Member
Apr 5, 2018
87
15
8
England
cPanel Access Level
Root Administrator
Twitter
allow_url_fopen It's enabled in the php.ini after that change - do you have anything in the .htaccess?

You definitely have php7.3 installed - is it set as the PHP handler for that version of PHP in MultiPHP manager within WHM?

# php -- BEGIN cPanel-generated handler, do not edit
# Set the “ea-php73” package as the default “PHP” programming language.
<IfModule mime_module>
AddHandler application/x-httpd-ea-php73 .php .php7 .phtml
</IfModule>
# php -- END cPanel-generated handler, do not edit

# BEGIN cPanel-generated php ini directives, do not edit
# Manual editing of this file may result in unexpected behavior.
# To make changes to this file, use the cPanel MultiPHP INI Editor (Home >> Software >> MultiPHP INI Editor)
# For more information, read our documentation (https://go.cpanel.net/EA4ModifyINI)
<IfModule php7_module>
php_flag display_errors Off
php_value max_execution_time 600
php_value max_input_time 90
php_value max_input_vars 1000
php_value memory_limit 1024M
php_value post_max_size 100M
php_value session.gc_maxlifetime 1440
php_value session.save_path "/var/cpanel/php/sessions/ea-php72"
php_value upload_max_filesize 80M
php_flag zlib.output_compression Off
</IfModule>
<IfModule lsapi_module>
php_flag display_errors Off
php_value max_execution_time 600
php_value max_input_time 90
php_value max_input_vars 1000
php_value memory_limit 1024M
php_value post_max_size 100M
php_value session.gc_maxlifetime 1440
php_value session.save_path "/var/cpanel/php/sessions/ea-php72"
php_value upload_max_filesize 80M
php_flag zlib.output_compression Off
</IfModule>
# END cPanel-generated php ini directives, do not edit


Odd, looks like it's still referencing 7.2? Looks like suPHP is the handler for 7.3 (in fact for all versions of PHP, within WHM)
 

inteldigital

Well-Known Member
Apr 5, 2018
87
15
8
England
cPanel Access Level
Root Administrator
Twitter
The Detached PHP processes got us. Try going into WHM and the LiteSpeed page. Click on "Restarted Detached PHP Processes" and see if that helps.
Thanks, that has seemed to have helped actually. Thanks @cPanelLauren for that documentation, so am I right in thinking that I don't need to worry that there appears to be a handler missing for PHP 7.3 in LiteSpeed Web Panel?
 

cPanelLauren

Technical Support Community Manager
Staff member
Nov 14, 2017
13,304
1,249
313
Houston
Thanks, that has seemed to have helped actually. Thanks @cPanelLauren for that documentation, so am I right in thinking that I don't need to worry that there appears to be a handler missing for PHP 7.3 in LiteSpeed Web Panel?
According to that documentation, nope.