The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Allowing smtp for specific domains

Discussion in 'E-mail Discussions' started by menamiketrx, Sep 19, 2006.

  1. menamiketrx

    menamiketrx Registered

    Joined:
    Jun 26, 2006
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Some of my customers were using Direcway Satelite for ISP. Now that they are Hughes, they no longer will handle third party smtp. I would like to allow a few of my customers that are impacted by this to utilize my server for smtp. How do I turn on this functions for only specific domains?

    Oh.... use great detail in describing the process, as I am very new to all of this.

    Thanks Bunch!
    Mike
     
  2. jayh38

    jayh38 Well-Known Member

    Joined:
    Mar 3, 2006
    Messages:
    1,215
    Likes Received:
    0
    Trophy Points:
    36
    Turn this function on? Email is available on every accountby default. Could you explain the limitations you are trying to overcome? They can use webmail, imap or pop clients. You say they are already clients, so they can just setup their own email account in their own cpanel, yes?
     
  3. menamiketrx

    menamiketrx Registered

    Joined:
    Jun 26, 2006
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Direcway will not allow SMTP of 3rd party domains e-mails

    I'll try again to explain. My e-mail account has been active for a decade. I use Direcway satelite for my ISP. They will no long allow 3rd party e-mails, to use their SMTP. Thus all my customers in the rural area that are with Direcway can no longer send mail as Direcway will not allow. They can receive mail, but not send. Most of these customers use outlook or eurora, and only occasionally access their mail by web mail. I would like to let them use my server as their SMTP. You say that this is default set up, but I cannot get it to work. I have tried setting up the outgoing mail preference as smtp@mydomain.com or mail@mydomain.com and I have tried the authorize SMTP on and off in the e-mail client. So I figure there must me something within C-Panel to set to allow this???

    Mike
     
  4. RickG

    RickG Well-Known Member

    Joined:
    Feb 28, 2005
    Messages:
    238
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    North Carolina
    There are probably two things that need to be done:

    1) Have you opened up another port for email? If your ISP is blocking port 25 (not uncommon), than you will need to open up a different port on the server for outbound mail.

    Look under WHM -> Service Configuration -> Service Manager. On the very bottom of the right frame is an option: exim on another port. Check this and define an alternate port number. I would use 26 or 587.

    2) After this is complete, you'll need to adjust the settings in your email client. Doesn't matter if you are using Outlook, Thunderbird, etc. -- under the email account there is a spot where you can define advanced settings. You'll need to make sure you indicate:
    - My Outgoing Server (SMTP) requires authentication
    - You'll also need to change the Outgoing Server port from 25 to 587 (if that is the port you defined above).
     
  5. menamiketrx

    menamiketrx Registered

    Joined:
    Jun 26, 2006
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Thanks Rick....

    I will give this a try.

    Mike
     
Loading...

Share This Page