SOLVED Almalinux Conversion Completed but Banner remains as CentOS

thowden

Well-Known Member
May 17, 2013
56
5
58
cPanel Access Level
Root Administrator
Hi All

I have just run my first Almalinux conversion on a CPanel / CentOS 8 server.

Followed the linked help page How to convert from CentOS 8 to AlmaLinux 8

Got to the end smoothly, ran the checks, and ran them again after a graceful restart, and again after a Forceful restart:

[[email protected] ~]# cat /etc/redhat-release
AlmaLinux release 8.4 (Electric Cheetah)
[[email protected] ~]# grubby --info DEFAULT | grep AlmaLinux
title="AlmaLinux (4.18.0-305.19.1.el8_4.x86_64) 8.4 (Electric Cheetah)"

Which appears to be correct.

I also listed this without the grep filter to see what else was there:

[[email protected] ~]# grubby --info DEFAULT
index=0
kernel="/boot/vmlinuz-4.18.0-305.19.1.el8_4.x86_64"
args="ro net.ifnames=0 biosdevname=0 quiet elevator=noop pti=off nomodeset nofb vga=normal console=tty1 console=ttyS0 console=hvc0 $tuned_params"
root="UUID=585d1221-1b46-4cf6-b546-b469d900d1d2"
initrd="/boot/initramfs-4.18.0-305.19.1.el8_4.x86_64.img $tuned_initrd"
title="AlmaLinux (4.18.0-305.19.1.el8_4.x86_64) 8.4 (Electric Cheetah)"
id="d44eb31881b145239791fd745a8c11c2-4.18.0-305.19.1.el8_4.x86_64"

All of which seems to in order, but I still get this:

1631909986830.png
The banner still indicates Centos 8 and asks me to convert ? Surely that banner should change and the nag panel disappear?

If it makes a difference this VM is on Xen hypervisor.
 
Last edited by a moderator:

thowden

Well-Known Member
May 17, 2013
56
5
58
cPanel Access Level
Root Administrator
Hi

Thanks.

[[email protected] ~]# yum update
Last metadata expiration check: 1:40:30 ago on Sat 18 Sep 2021 06:05:13 AM AEST.
Dependencies resolved.
Nothing to do.
Complete!

Seems like nothing there, but will restart in any case.

I started down this path with the goal of installing Cloudlinux, and I think I will go ahead with that as, other than the banner, everything seems to align as done.
 

thowden

Well-Known Member
May 17, 2013
56
5
58
cPanel Access Level
Root Administrator
Hi

Hmmm....

=> Log opened from /usr/local/cpanel/scripts/updatenow (6284) at Sat Sep 18 08:09:46 2021
[2021-09-18 08:09:46 +1000] Running version '11.98.0.7' of updatenow.
[2021-09-18 08:09:46 +1000] Detected version '11.98.0.7' from version file.
[2021-09-18 08:09:46 +1000] Target version set to '11.98.0.7'
[2021-09-18 08:09:46 +1000] Up to date (11.98.0.7)
=> Log closed Sat Sep 18 08:09:46 2021
----------------------------------------------------------------------------------------------------
=> Log opened from cPanel Update (upcp) - Slave (4852) at Sat Sep 18 08:09:46 2021
[2021-09-18 08:09:46 +1000] 95% complete
[2021-09-18 08:09:46 +1000] Running Standardized hooks
[2021-09-18 08:09:46 +1000] 100% complete
[2021-09-18 08:09:46 +1000]
[2021-09-18 08:09:46 +1000] cPanel update completed
[2021-09-18 08:09:46 +1000] A log of this update is available at /var/cpanel/updatelogs/update.4852.96664.1631915337.log
[2021-09-18 08:09:46 +1000] Removing upcp pidfile
[2021-09-18 08:09:46 +1000]
[2021-09-18 08:09:46 +1000] Completed all updates
=> Log closed Sat Sep 18 08:09:46 2021

Reboot and voila! That did the trick. Thanks.
 
Last edited:
  • Like
Reactions: cPRex
Thread starter Similar threads Forum Replies Date
Z Operating Systems 5
A Operating Systems 0