SOLVED [ALTPHP-557] quickhash extension unable to load with alt-php

Tarak Nath

Well-Known Member
Mar 12, 2018
91
14
8
India
cPanel Access Level
Root Administrator
Hello,

We are getting below error in our site, also attached screenshot.

=================
Message: PHP Startup: Unable to load dynamic library '/opt/alt/php56/usr/lib64/php/modules/quickhash.so' - /opt/alt/php56/usr/lib64/php/modules/quickhash.so: undefined symbol: qha_jenkins2
=================

We have only cPanle access not WHM. Any information about how to get this resolved would be greatly appreciated.

Regards,
Tarak Nath
 

Attachments

rpvw

Well-Known Member
Jul 18, 2013
1,101
462
113
UK
cPanel Access Level
Root Administrator

Tarak Nath

Well-Known Member
Mar 12, 2018
91
14
8
India
cPanel Access Level
Root Administrator
Thank you !

We will try to reach our hosting provider.

In the meantime, is there anyway to resolve this issue without root access ?

Regards,
Tarak Nath
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,228
463
We will try to reach our hosting provider.

In the meantime, is there anyway to resolve this issue without root access ?
Hello @Tarak Nath,

The error message you provided suggests CloudLinux is installed on the system. You should see a PHP Selector option in cPanel if your hosting provider has enabled that feature. If so, you could try switching to a different PHP version to see if the issue persists.

Thank you.
 

Tarak Nath

Well-Known Member
Mar 12, 2018
91
14
8
India
cPanel Access Level
Root Administrator
Hello @cPanelMichael ,

Thank you for the suggestion !

We developed our site in ALT-PHP 5.6 environment where everything working fine and uploaded the same developed files and databases on production environment with same version of PHP 5.6. But we are getting above error. We don't understand why we are getting such a this type of issue as the both environment are same. For this we have contacted with CloudLinux support and below is the feedback:

=-=-=-=-=-=-=-=-=-=-=
I have created a task for our dev. team in order to check the issue with this extension. The internal task id: ALTPHP-557
Right now I see only one way to get this extension to work is the manual compilation with further replace of the current one.

=-=-=-=-=-=-=-=-=-=-=

And below is the 2nd feedback once we follow up:
=-=-=-=-=-=-=-=-=-=-=
As we mentioned before, we have created an internal task for our developers (ALTPHP-557) to investigate this problem further.
It may take some time before this issue will be addressed. We will inform you as soon as we have more information.

=-=-=-=-=-=-=-=-=-=-=
We are still not getting the final feedback of their DEV team.

However, as per your suggestion we have switched the PHP version from 5.6 to 5.4 then the issue resolved and the site is functioning & working fine as expected.

But we are still not understand why its not working through ALT-PHP 5.6.

Thanks again :)

Regards,
Tarak Nath
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,228
463
Hello @Tarak Nath,

I'm monitoring CloudLinux internal case ALTPHP-557 and will update this thread with more information on it's status as it becomes available.

Thank you.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,228
463
Hello @Tarak Nath,

CloudLinux has not yet updated the case with more information or a specific time frame for a solution. I'll continue to monitor the case and update this thread with more information as it becomes available.

Thank you.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,228
463
Hello,

CloudLinux published an update to the alt-php packages today that includes a fix for ALTPHP-557:

Alt-PHP updated

Thank you.