The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Am i not receiving some mail?

Discussion in 'E-mail Discussions' started by damainman, Sep 17, 2004.

  1. damainman

    damainman Well-Known Member

    Joined:
    Nov 13, 2003
    Messages:
    515
    Likes Received:
    0
    Trophy Points:
    16
    I noticed this in WHM under the mail statistics:

    16 root@myserver.net: retry timeout exceeded

    I've also noticed i haven't received some mail that was sent there. It also list two of my other emails. These are email addresses located on my server.

    Does anyone know wat could be wrong, and how i could i correct it?

    Thank you in advance.
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Are you running MailScanner?

    If so, you should make sure that you have the following line in the first textbox within the Advanced Mode of the Exim Configuration Editor:

    queue_only_override = false

    If that's not the issue, then a search of /var/log/exim_rejectlog for root might be a goos starting place.
     
  3. damainman

    damainman Well-Known Member

    Joined:
    Nov 13, 2003
    Messages:
    515
    Likes Received:
    0
    Trophy Points:
    16
    Thank you Chirpy.

    I just looked at the first Textbox, under where it says: #!!# cPanel Exim 4 Config


    And no it doesn't say: queue_only_override = false

    I'm going to put it in now, but can you tell me what that does? I'm using the old modified layer1 mailscanner installer that was posted on the forums a long time ago, before you came out with your recent install script.

    Is there any other configurations I should have made?

    Another thing i noticed in the statistics page was this:

    Under "Grand total summary" near the top, it displays thigh:

    At least one address
    Delayed Failed
    45 1.5% 121 4.2%
     
  4. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    The line prevents the root account from overriding your queue configuration. This restriction is required in a MailScanner installation because of the way the sending and receiving queues are split. Without it, root emails (especially CRON emails) can get lost.
     
  5. puzz1ed1

    puzz1ed1 Active Member

    Joined:
    Jan 31, 2004
    Messages:
    39
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Thurrock, UK
    Jonathan,

    just noticed that MailScanner had stopped working over night - adding this line back into exim.conf fixed it, but it always used to be there (as you know, it was all working OK... eventually :rolleyes: )

    I'm guessing it's down to a cPanel update and therefore could stop again at any time without us knowing until everyone gets lots of spam - is there a way of checking on this via CRON??

    Steve
     
  6. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    You didn't install the clamavconnector did you?
     
  7. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Actually, I've just discovered that if you have cPanel Pro installed via WHM > Add-on Modules, when it upgrades, it doesn't bother running:

    /scripts/mailscannerupdate

    Which you need to do. Looks like cPanel are trying to break MailScanner.
     
  8. damainman

    damainman Well-Known Member

    Joined:
    Nov 13, 2003
    Messages:
    515
    Likes Received:
    0
    Trophy Points:
    16
    hey chirpy i looked through all all the text boxes in exim, and they were all emtpy. However i ran the /scripts/mailscanner update, and now in the 3rd text both it displays this:

    Is this safe to keep, or should it be modified or something?

    Thank you for all your help :)
     
  9. puzz1ed1

    puzz1ed1 Active Member

    Joined:
    Jan 31, 2004
    Messages:
    39
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Thurrock, UK
    not after last weekend, no! :D
     
  10. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    That's normal and would have been there before :)
     
  11. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Ah!, Yes, I remember now ;)
     
Loading...

Share This Page