Amazon SES says unverified because it sends from root instead of my account?

Atrix

Member
Sep 7, 2012
9
2
3
cPanel Access Level
Root Administrator
The server was bought from hostgator, and was given some we'll never use it domain name, we'll call it notused.com

I followed Amazon's instructions to get the server working: http://docs.aws.amazon.com/ses/latest/DeveloperGuide/exim.html

It worked but I also had to do this:
cd /var/spool/exim/db
rm -f retry retry.lockfile
rm -f wait-remote_smtp wait-remote_smtp.lockfile
service exim restart

To get rid of (-53) errors.

I did that, and got email not verified. So I verified both the name and email address. But I still get that it's not verified and when I send the email from squirrelmail via cpanel, it comes back with this (I changed email and IP for obvious reason):

Code:
  [email protected]
  host ses-smtp-us-west-2-prod-14896026.us-west-2.elb.amazonaws.com [54.69.81.169]
  SMTP error from remote mail server after end of data:
  554 Message rejected: Email address is not verified.

------ This is a copy of the message, including all the headers. ------

Return-path: <[email protected]>
Received: from localhost ([127.0.0.1]:39653 helo=[xxx.xxx.xxx.xxx])
  by notused.com with esmtpa (Exim 4.85)
  (envelope-from <[email protected]>)
  id ------------
  for [email protected]; Mon, 27 Apr 2015 17:52:49 -0500
Received: from xxx.xxx.xxx.xxx ([xxx.xxx.xxx.xxx])
  (SquirrelMail authenticated user [email protected])
  by xxx.xxx.xxx.xxx with HTTP;
  Mon, 27 Apr 2015 17:52:49 -0500
Message-ID: <[email protected]>
Date: Mon, 27 Apr 2015 17:52:49 -0500
Subject: testing ses
From: "Name" <[email protected]>
To: [email protected]
User-Agent: SquirrelMail/1.5.2 [SVN]
MIME-Version: 1.0
Content-Type: text/plain;charset=iso-8859-1
Content-Transfer-Encoding: 8bit

testing ses
Why is is the header saying by notused.com for [email protected], I feel that's what is making it fail, since it sees that notused.com instead of the expected ourdomain.com, why does notused.com ever come into play at all????
 
Last edited by a moderator:

Atrix

Member
Sep 7, 2012
9
2
3
cPanel Access Level
Root Administrator
Ok, I got it to work. The problem is it reports that message for all emails sent unless you send to their mailbox simulator. It is like this until you create a ticket with Amazon SES to take your setup out of sandbox mode. They don't make this obvious at all so I am leaving this here for anyone who might stumble on this from a search engine.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,225
463
Hello,

I am happy to see you were able to resolve the issue. Thank you for updating us with the outcome.