The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Amount of files by FTP firewall CSF blocks my IP

Discussion in 'General Discussion' started by zimbahost, May 17, 2010.

  1. zimbahost

    zimbahost Active Member

    Joined:
    Feb 17, 2009
    Messages:
    34
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Brazil
    Hello, because when I send a certain amount of files by FTP firewall CSF blocks my IP, just reset the modem to re-run and FTP access and to the server.

    Log CSF

    May 17 08:41:39 valente lfd[7780]: *Port Scan* detected from 187.55.4.1XX (BR/Brazil/-). 11 hits in the last 70 seconds - *Blocked in csf* for 3600 secs

    See http://forum.configserver.com/showthread.php?p=8494

    Thanks
    Maison
     
    #1 zimbahost, May 17, 2010
    Last edited: May 17, 2010
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,480
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Not sure I understand the post, are you asking a question? It sounds to me like you're exceeding the number of connections allowed by your configuration. An easy way around that for the average user is to simply upload a compressed file and extract on the server via File Manager or command line.

    If you believe it's a problem with CSF, you might try configserver forums for assistance.
     
  3. zimbahost

    zimbahost Active Member

    Joined:
    Feb 17, 2009
    Messages:
    34
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Brazil
    FTP from my computer is configured for connection 7, and server 80 connections per ip.
    I send file more normal when it comes to 60 files sent it blocks.
    If I send 50 files will not block
    7 files are sent at a time,
     
  4. zimbahost

    zimbahost Active Member

    Joined:
    Feb 17, 2009
    Messages:
    34
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Brazil
  5. zimbahost

    zimbahost Active Member

    Joined:
    Feb 17, 2009
    Messages:
    34
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Brazil
  6. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,480
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    I got your PM, but don't use MSN nor provide support outside of these forums for this sort of thing, sorry.

    The reply from chirpy in the thread link you've added since my original post seems to speak for itself, IMO. I'm not sure what more can be added to this other than to ask why is your FTP client showing up in your logs as doing port scans?

    What FTP client are you using and have you checked your client settings for something that may be causing the problem on your end locally? Also, have you tried a different FTP client just to troubleshoot the issue?

    Other ways around the problem (besides what chirpy has suggested in that thread) might include adding your IP to the bypass list so that you're not bothered by your systems firewall rules if you're the Administrator. And, as was already mentioned, if you must upload 60 or more files at one time, compress them first into a zip file and unpack on the server. With only one connection made to upload that compressed file, no blocks should take place. And btw is much faster than uploading 60 files 7 at a time.

    If your FTP client is not letting go of the connection after a file is uploaded I suppose that could cause some problems with the max number of connections you make to the server, but why are they showing up as port scans and not too many connections block?


    Hey, that was my 4,000th post! :p
     
  7. Secmas

    Secmas Well-Known Member

    Joined:
    Feb 18, 2005
    Messages:
    321
    Likes Received:
    0
    Trophy Points:
    16
    I see you are using FILEZILLA as your FTP client, well, do the following:
    1. EDIT
    2. SETTINGS
    3. TRANSFERS
    in that window modify the following parameters, to have all the same value:
    Maximum Simultaneous Transfers: 3
    Limit for concurrent Downloads: 3
    Limit for Concurrent Uploads: 3
    or modify the value until you found one that is ok for you. In my case 3 is the optimum with my Internet connection and with my server.

    Doing this you will not have more errors with your FTP.

    Regards,

    Sergio

    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~

    Vejo que você está usando FileZilla como seu cliente de FTP, bem, faça o seguinte:
    1. EDIT
    2. CONFIGURAÇÕES
    3. TRANSFERS
    na janela que modificar os seguintes parâmetros, para que todos o mesmo valor:
    Transferências máxima simultânea: 3
    Limite de downloads simultâneos: 3
    Limite para uploads simultâneos: 3
    ou modificar o valor até que encontrei um que está OK para você. No meu caso 3 é o melhor com a minha conexão com a Internet e com o meu servidor.

    Fazendo isso, você não terá mais erros com o seu FTP.

    Atenciosamente,

    Sergio
     
  8. zimbahost

    zimbahost Active Member

    Joined:
    Feb 17, 2009
    Messages:
    34
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Brazil
    Yes, more about the customer?

    _____________________________


    Sim, mais quanto ao cliente?
     
  9. Secmas

    Secmas Well-Known Member

    Joined:
    Feb 18, 2005
    Messages:
    321
    Likes Received:
    0
    Trophy Points:
    16
    Customers use the same value.
     
  10. zimbahost

    zimbahost Active Member

    Joined:
    Feb 17, 2009
    Messages:
    34
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Brazil
    My customer use 7 default
    What do I need for them to continue using 7?

    Thansk you replay
     
  11. zimbahost

    zimbahost Active Member

    Joined:
    Feb 17, 2009
    Messages:
    34
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Brazil
    Thanks for the tip will I follow them.
    I hope that the customers also

    Thanks to everyone who posted.
     
  12. Secmas

    Secmas Well-Known Member

    Joined:
    Feb 18, 2005
    Messages:
    321
    Likes Received:
    0
    Trophy Points:
    16
    Don't use 7 is not worth it, speed will not see any improvement, try using "3", that will help you a lot.

    But you can try 7 instead of 3 and check how that goes.

    The problem using 7 is that you will see a lot of uploads that will be idle, but you can try.
     
Loading...

Share This Page