SOLVED An Error Occurred While Attempting To Check Whether Running Executables Are Up-to-Date


Well-Known Member
Aug 21, 2015
cPanel Access Level
Root Administrator
In Security Advisor, I'm getting the message:
An error occurred while attempting to check whether running executables are up-to-date: The “/usr/bin/needs-restarting” command (process 71245) reported error number 1 when it ended.
If I manually run /usr/bin/needs-restarting, I get the following:
Traceback (most recent call last):
  File "/usr/bin/needs-restarting", line 173, in <module>
  File "/usr/bin/needs-restarting", line 154, in main
    for oldpkg in my.pkgSack.searchFiles(just_fn): # ghostfiles are always bogons
  File "/usr/lib/python2.6/site-packages/yum/", line 472, in searchFiles
    return self._computeAggregateListResult("searchFiles", name)
  File "/usr/lib/python2.6/site-packages/yum/", line 599, in _computeAggregateListResult
    sackResult = apply(method, args)
  File "/usr/lib/python2.6/site-packages/yum/", line 46, in newFunc
    return func(*args, **kwargs)
  File "/usr/lib/python2.6/site-packages/yum/", line 957, in searchFiles
    self.populate(repo, mdtype='filelists')
  File "/usr/lib/python2.6/site-packages/yum/", line 184, in populate
    xml = repo_get_function()
  File "/usr/lib/python2.6/site-packages/yum/", line 1679, in getFileListsXML
    return self.retrieveMD('filelists')
  File "/usr/lib/python2.6/site-packages/yum/", line 1571, in retrieveMD
    return self._retrieveMD(mdtype)
  File "/usr/lib/python2.6/site-packages/yum/", line 1654, in _retrieveMD
  File "/usr/lib/python2.6/site-packages/yum/", line 842, in _getFile
    raise Errors.NoMoreMirrorsRepoError, errstr
yum.Errors.NoMoreMirrorsRepoError: failure: repodata/filelists.xml.gz from stable-generic: [Errno 256] No more mirrors to try.
My list of mirrors with "ls -al /etc/yum.repos.d" is:
total 48
drwxr-xr-x.  2 root root  4096 Jul 18 06:29 ./
drwxr-xr-x  99 root root 16384 Jul 18 13:24 ../
-rw-r--r--   1 root root   244 Jul 18 06:29 cPAddons.repo
-rw-r--r--   1 root root   243 Apr 20 20:55 EA4-experimental.repo
-rw-r--r--   1 root root   204 Apr 20 20:54 EA4.repo
-rw-r--r--   1 root root   119 Jul 13 05:30 kernelcare.repo
-rw-r--r--   1 root root   119 Mar 28 01:29 kernelcare.repo.rpmnew
-rw-r--r--   1 root root   469 Mar 16  2016 yum.sourcedns.repo
-rw-r--r--   1 root root   606 Mar 16  2016 yum.system.repo
I don't think it's related, but Security Advisor is also telling me:
Kernel patched with KernelCare, but awaiting further updates. running kernel: 2.6.32-696.3.2.el6, most recent kernel: 2.6.32-696.6.3.el6.x86_64

The kernel will likely be patched to the current version within the next few days. If this delay is unacceptable, update the system’s software by running ’yum update’ from the command line and reboot the system.
How do I resolve the issue with /usr/bin/needs-restarting?


Well-Known Member
Aug 21, 2015
cPanel Access Level
Root Administrator
I ran "yum clean all", and it got rid of the error message in Security Advisor regarding /usr/bin/needs-restarting, giving the following output:
Loaded plugins: changelog, fastestmirror, priorities, security, tsflags,
: universal-hooks
Cleaning repos: EA4 cpanel-addons-production-feed kernelcare stable-arch
: stable-generic stable-noarch system-base system-extras
: system-updates-released
Cleaning up Everything
Cleaning up list of fastest mirrors
After that, Security Advisor had the message:
Detected processes that are running outdated binary executables.Reboot the system in the “Graceful Server Reboot” area. Alternatively, SSH into this server and run ‘/usr/bin/needs-restarting’, then manually restart each of the listed processes.
I did the graceful server reboot, and it resolved the problem with the outdated binary executables and now the kernel is also up-to-date.

You can mark this one solved. Thank you!
  • Like
Reactions: cPanelMichael


Staff member
Apr 11, 2011
I'm happy to see the issue is now solved. Thank you for updating us with the outcome.