The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

([an error occurred while processing this directive])

Discussion in 'General Discussion' started by newguy, Jan 2, 2009.

  1. newguy

    newguy Member

    Joined:
    Jan 2, 2009
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    PHP:
    isdedicatedip() requires one argument (this probably means a domain is missing from httpd.conf) at /usr/local/cpanel/Cpanel/DIp.pm line 45
        Cpanel::DIp::isdedicatedip(undef) called at /usr/local/cpanel/Cpanel/ExpVar.pm line 283
        Cpanel::ExpVar::expvar('!$hasdedicatedip') called at /usr/local/cpanel/Cpanel/StatsBar.pm line 230
        Cpanel::StatsBar::api2_stat('rowcounter', 'mainstats', 'display', 'hostingpackage|shorthostname|cpanelversion|cpanelrevision|theme|...') called at (eval 106) line 1
        eval '$dataref = [Cpanel::StatsBar::api2_stat(%CFG)];' called at cpanel.pl line 4945
        main::api2_exec('StatsBar', 'stat', 'HASH(0xa3977e8)', 'HASH(0x93ecd38)') called at cpanel.pl line 1469
        main::cpexectag('<?cp StatsBar::stat([tr class="row-%"][td width="40\{percent}" a...') called at cpanel.pl line 4742
        main::dotag(undef) called at cpanel.pl line 4625
        main::cpanel_parseblock('SCALAR(0x9b1d014)') called at cpanel.pl line 4577
        main::cpanel_parse('GLOB(0x97002c0)') called at cpanel.pl line 2855
        main::doinclude('/usr/local/cpanel/base/frontend/x3/branding/index.html', 0, 1) called at /usr/local/cpanel/Cpanel/Branding.pm line 95
        Cpanel::Branding::Branding_include('index.html') called at (eval 7) line 1
        eval 'Cpanel::Branding::Branding_include(@{$argref});' called at cpanel.pl line 1637
        main::exectag('<cpanel Branding="include(index.html)">') called at cpanel.pl line 4742
        main::dotag(undef) called at cpanel.pl line 4625
        main::cpanel_parseblock('SCALAR(0x93a5ef0)') called at cpanel.pl line 4577
        main::cpanel_parse('GLOB(0x96c6548)') called at cpanel.pl line 1303
        Carp::cluck('isdedicatedip() requires one argument (this probably means a dom...') called at /usr/local/cpanel/Cpanel/DIp.pm line 45
        Cpanel::DIp::isdedicatedip(undef) called at /usr/local/cpanel/Cpanel/ExpVar.pm line 283
        Cpanel::ExpVar::expvar('!$hasdedicatedip') called at /usr/local/cpanel/Cpanel/StatsBar.pm line 230
        Cpanel::StatsBar::api2_stat('rowcounter', 'mainstats', 'display', 'hostingpackage|shorthostname|cpanelversion|cpanelrevision|theme|...') called at (eval 106) line 1
        eval '$dataref = [Cpanel::StatsBar::api2_stat(%CFG)];' called at cpanel.pl line 4945
        main::api2_exec('StatsBar', 'stat', 'HASH(0xa3977e8)', 'HASH(0x93ecd38)') called at cpanel.pl line 1469
        main::cpexectag('<?cp StatsBar::stat([tr class="row-%"][td width="40\{percent}" a...') called at cpanel.pl line 4742
        main::dotag(undef) called at cpanel.pl line 4625
        main::cpanel_parseblock('SCALAR(0x9b1d014)') called at cpanel.pl line 4577
        main::cpanel_parse('GLOB(0x97002c0)') called at cpanel.pl line 2855
        main::doinclude('/usr/local/cpanel/base/frontend/x3/branding/index.html', 0, 1) called at /usr/local/cpanel/Cpanel/Branding.pm line 95
        Cpanel::Branding::Branding_include('index.html') called at (eval 7) line 1
        eval 'Cpanel::Branding::Branding_include(@{$argref});' called at cpanel.pl line 1637
        main::exectag('<cpanel Branding="include(index.html)">') called at cpanel.pl line 4742
        main::dotag(undef) called at cpanel.pl line 4625
        main::cpanel_parseblock('SCALAR(0x93a5ef0)') called at cpanel.pl line 4577
        main::cpanel_parse('GLOB(0x96c6548)') called at cpanel.pl line 1303
    Can any one help with this? Also in my WHM the same account is showing IP as missing. The site is working though.
     
  2. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    What action are you attempting to perform when you get this error?
     
  3. webbytech

    webbytech Member

    Joined:
    Dec 22, 2008
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Illinois
    David,
    Im getting a similar issue on Stable 27698 when creating packages as root.
     
  4. newguy

    newguy Member

    Joined:
    Jan 2, 2009
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    This was resolved for me. Sorry for the late reply.
     
  5. readywire

    readywire Member

    Joined:
    Apr 9, 2004
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Please be sure to post how you fixed the issue. :)
     
  6. newguy

    newguy Member

    Joined:
    Jan 2, 2009
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    This problem was not causing me any problems at all. The site was running fine. Two weeks later I turned in the server and got another server from the same data center. They had a super deal weekend and I got much more for less money. I never got this problem solved before the server move.
     
Loading...

Share This Page