an unknown filter was not added: DEFLATE

cPanelTristan

Quality Assurance Analyst
Staff member
Oct 2, 2010
7,607
40
248
somewhere over the rainbow
cPanel Access Level
Root Administrator
Hello,

This error message would mean that someone is using mod_deflate code in an .htaccess file, but your server doesn't have mod_deflate installed.

If you want to install mod_deflate, simply use WHM > EasyApache (Apache Update) or /scripts/easyapache to add DEFLATE in the Exhaustive Options List for Apache 2 / 2.2.

You can check to confirm it isn't installed using this command in root SSH:

Code:
/usr/local/apache/bin/apachectl -M | grep -i deflate
Thanks!
 

nixgurus

Member
Feb 16, 2011
20
0
51
Google
cPanel Access Level
Root Administrator
When I try to run given command I got following response

Code:
[email protected] [~]# /usr/local/apache/bin/apachectl -M | grep -i deflate
Warning: DocumentRoot [/home/hopeup/public_html/hopeuplift/gallery/school] does not exist
Warning: DocumentRoot [/home/problog/public_html/t5] does not exist
Syntax OK
[email protected] [~]#
I checked mentioned directories are missing but how I can trace the exact cause of this log entry ?

Code:
[error] an unknown filter was not added: DEFLATE
 

cPanelTristan

Quality Assurance Analyst
Staff member
Oct 2, 2010
7,607
40
248
somewhere over the rainbow
cPanel Access Level
Root Administrator
As I mentioned, if you don't have mod_deflate, you'd get that error. To resolve it, install it:

If you want to install mod_deflate, simply use WHM > EasyApache (Apache Update) or /scripts/easyapache to add DEFLATE in the Exhaustive Options List for Apache 2 / 2.2.
Otherwise, you'd have to do a search of .htaccess files that might have entries for it.