Anacron | Still issue accrue with other RPM

nadav123

Well-Known Member
Mar 2, 2020
159
18
18
Orlando, FL
cPanel Access Level
Root Administrator
OK, First.
I want to say thanks to cPRex, save my server last time :)
It was only an RPM package, but still, to install RPM manual an operating system like cPanel can be catastrofical results.

So... thank you cPRex.
( Helping me SUPER fast i was shocked, this forum save a lot of people i assure you that )

Now, for that Anacron isiue. (it's not an emergency ).

I think the issue connected to 3rd Party "Engintron" ( i am not 100% sure, i still check it )

I notice now after we fix this issue:

I notice the email message (0yum-daily.cron)
stop after forcing cPanel update throw WHM.

After that,
I delete Engintron completely and after that
I installed Engintron again. ( This because: "Engintron" hooks himself to the crontab, it's needed to refresh the installation ).

Now, when i did it.
I started gets the emails warning from: /etc/cron.daily/0yum-daily.cron (Sometimes the emails note it's Anacron, sometime without Anacron)
So we comeback to similler isiue as before with MariaDB, but now the email with other Repo problem (nginx repo):
Code:
Anacron job 'cron.daily' on server.locksmithunit.com
Trash

Anacron <[email protected]>
8:27 AM (7 hours ago)
to root

/etc/cron.daily/0yum-daily.cron:

Not using downloaded nginx/repomd.xml because it is older than what we have:
  Current   : Wed Jan 26 05:52:53 2022
  Downloaded: Tue Jan 25 10:45:56 2022

This time it is this:
nginx/repomd.xml

Now, i know it's 3rd party, but the Repo's repository belongs to cPanel no? ( cPanel has a unique repository ).
I tried to install Engintron again and again,
With a hope, maybe, Reinstalling and installing will automatically download it from another repository.
but no luck... :(
and still getting these emails from CRON every hour.

I suspect on 2 things. (if i can, of course, hope to get help with this issue):

1. From the last cPanel update you install some cron feature (Anacron or something like that), and this any hour chacks the Repo's.

2. Engintron install Anacron? ( I'm not sure about that, its speculations )


I Know its 3rd a party, so in case you will not be able to help me to get the Engintron Repo's from the cPanel repository, i publish on his forum as well:


For this case you can help me, to get Engintron from the cPanel repository ( after all its a repository of cPanel, not Engintron )

But i will understand if you cant help me cPRex.
Anyway...
Thank you, and this issue is not an emergency case, my server running including the website.

I only want to solve the Anacron issue with the emails and keep the Anacron feature if neccery.
( i prefer understanding the problem and not ignoring it )

Hope it's was clear to understand, help me please cPRex. ( if you can of course - if this is actually from cPanel and not Engintron )
And thanks again, really, you save me last time.
 
Last edited:

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
10,360
1,628
363
cPanel Access Level
Root Administrator
Hey hey! I'm glad the MySQL situation got fixed!

cPanel doesn't provide Engintron, so there wouldn't be anything available from our repositories for that software.

To help with the repo issues, can you try running these commands?

Code:
yum clean all
yum makecache
Those will clear the Yum data and refresh it, ensuring your repository information is up to date.
 

nadav123

Well-Known Member
Mar 2, 2020
159
18
18
Orlando, FL
cPanel Access Level
Root Administrator
Thanks, bro :)
you do great service here really, i sure like you save me, you saved many others.

Now for our issue.

I did what you said and it's look good.
I run the commands you told me and imidate after i click on the WHM interface:

  • WHM » Software » System Update

I got this in the interface:
Code:
System update process has started.
---> Package nginx.x86_64 1:1.20.2-1.el7.ngx will be updated
---> Package nginx.x86_64 1:1.21.6-1.el7.ngx will be an update
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package       Arch           Version                       Repository     Size
================================================================================
Updating:
 nginx         x86_64         1:1.21.6-1.el7.ngx            nginx         796 k

Transaction Summary
================================================================================
Upgrade  1 Package

Total download size: 796 k
Downloading packages:
No Presto metadata available for nginx
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Updating   : 1:nginx-1.21.6-1.el7.ngx.x86_64                              1/2
warning: /etc/nginx/mime.types created as /etc/nginx/mime.types.rpmnew
  Cleanup    : 1:nginx-1.20.2-1.el7.ngx.x86_64                              2/2
  Verifying  : 1:nginx-1.21.6-1.el7.ngx.x86_64                              1/2
  Verifying  : 1:nginx-1.20.2-1.el7.ngx.x86_64                              2/2

Updated:
  nginx.x86_64 1:1.21.6-1.el7.ngx                                               

Complete!

System update process has finished.
as you see it's Nginx, i think you did the job well :)
I gonna wait 1 hour now to see if the emails stop.
(I think its stop, its download the REPO again as you see)

Hahaha thanks again cPRex, you are a lifesaver :)

______

only one last question:

it's good to make cronjob with the command line you offer and refresh the REPOS every week?
for example:

Code:
# YUM Script | Clean cache from all the Repo's
25 0 * * 3 root yum clean all >> /dev/null 2>&1

# YUM Script | Make cache to all the Repo's
30 0 * * 3 root yum makecache >> /dev/null 2>&1


Please tell me if is a good cronjob or its not neccery,

I will update in 1 hour if we succeed to fix the REPO'S issue ( i will see if emails continue to come, it's every hour - but i am pretty sure your commend fix it.)