The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Anbody using Apache 2.0.5x ?

Discussion in 'EasyApache' started by nyjimbo, Aug 27, 2007.

  1. nyjimbo

    nyjimbo Well-Known Member

    Joined:
    Jan 25, 2003
    Messages:
    1,125
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    New York
    We would like to move from Apache 1.37 to 2.0.5x because some of our users can tell we are running the older stuff and want to know why. Yeah, we dont really need to go to 2.0 but they think it should be done so if its not painful to upgrade we would like to do it within the next month.

    Our servers run Freebsd 6.2, Cpanel 11 and all the latest stuff. Everything is intact and running easyapache is flawless so the machines are pretty solid. We want to keep php at 4.x and mysql at 4.x for now but would like to do the apache thing if possible. We already run 2.0 on our non-cpanel boxes so we know how to trouble shoot it manually, but we dont want to break the easyapache install and do it manually so our boxes maintain full cpanel/upcp/easyapache compatibilty.

    What do we need to prepare to go to 2.0 ?. We REALLY need to keep frontpage as well as ALL of our modules we have in 1.37.

    Thanks for any info, advice or guidance.

    :)
     
    #1 nyjimbo, Aug 27, 2007
    Last edited: Aug 27, 2007
  2. AtlantisService

    AtlantisService Active Member

    Joined:
    Mar 15, 2007
    Messages:
    33
    Likes Received:
    0
    Trophy Points:
    6
    Stage 2

    We're having the same problem. We've been using php5 for a few years now (2yrs) on all our servers and everything else is completely updated except for Apache with Cpanel. My advice would be to wait for Stage 2, as there are still some bugs in their support.

    Apache 2.2.4 is what we're looking forward too.
     
  3. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,461
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    The one that will be a killer is your need for FrontPage. We did some massive work to get FrontPage to support Apache 2.x, since the support was barely there. Other than that, as long as you use --prefix=/usr you should be fine. Well, that and making sure you get the correct modules. Oh, and make certain your httpd.conf is compatible with Apache 2.0, some of the directives changed.


    EDIT:
    Yeah, i just made the Ea3 delay seem nonsensicle. There is more to it than the above, far more. but for a simple, one machine answer, the above will work.
     
    #3 cPanelKenneth, Aug 27, 2007
    Last edited: Aug 27, 2007
Loading...

Share This Page