The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Anon FTP -- 553 Error --

Discussion in 'General Discussion' started by bmcpanel, Jun 22, 2003.

  1. bmcpanel

    bmcpanel Well-Known Member

    Joined:
    Jun 1, 2002
    Messages:
    546
    Likes Received:
    0
    Trophy Points:
    16
    553 Error: Anonymous users may not overwrite existing files

    I am using PURE-FTP on this server. This error happens for any domain name account I try.

    1. I have verified that anonymous FTP is on in WHM under Tweak FTP settings.
    2. I have verified that anonymous FTP is setup on the domain name.
    3. The accounts are using dedicated IPs (Don't know if this is an issue with Cpanel, but they are dedicated IPs for each account)
    4. I have tried using Internet Explorer and WS_FTP to upload anonymously.
    5. I am attempting to upload to the folder called "incoming"
    6. Permissions for the "public_ftp" and "incoming" folders are 755 and ownership is username.username (whereas "username" is the clients username.

    To sum up, I can navigate through the anonymous folders, but get the before-mentioned error message when attempting to upload. I tried uploading small files, big files, gifs, jpgs, .html files, .zip files, and any thing else I could think of. The error happens server wide on any account I attempt to upload with. Though the error says "can't overwrite existing files...", there are no files there to be overwritten.

    I checked /etc/pure-ftp.conf , and it seems to be configured to allow anon ftp uploads.

    Any idea what is wrong?

    cPanel.net Support Ticket Number:
     
  2. thedavid

    thedavid Well-Known Member

    Joined:
    Nov 22, 2002
    Messages:
    124
    Likes Received:
    0
    Trophy Points:
    16
    Same thing just started happening across all of our cpanel servers running on the latest release. We use pureftp as well. I've written to cpanel support and they didn't seem to be able to fix it. I'm subscribing to this thread - anyone else see this?

    We've done all of the above as well as checking the mappings for the files that pureftp uses, installing proftp and moving back to pureftp to see if that would work as cpanel support suggested, and nothing.

    In the end, the only thing that they could reccomend was to tell the clients to logon as anonymous@domainname.com, which didn't work either.

    Anyone else having this problem?

    -David

    cPanel.net Support Ticket Number:
     
  3. tAzMaNiAc

    tAzMaNiAc Well-Known Member

    Joined:
    Feb 16, 2003
    Messages:
    559
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Sachse, TX
    WHat systems are yall running? Curious. I have my anonymous OFF and DISABLED bec of security issues related to having those.

    Brenden

    cPanel.net Support Ticket Number:
     
  4. thedavid

    thedavid Well-Known Member

    Joined:
    Nov 22, 2002
    Messages:
    124
    Likes Received:
    0
    Trophy Points:
    16
    Both of our servers that are doing this are running on the latest cpanel release version.

    -David

    cPanel.net Support Ticket Number:
     
  5. Annette

    Annette Well-Known Member
    PartnerNOC

    Joined:
    Aug 12, 2001
    Messages:
    445
    Likes Received:
    0
    Trophy Points:
    16
    Edit /etc/sysconfig/pure-ftpd

    Find this and comment it out:

    # disallow uploads for anonymous users
    --anonymouscantupload

    So it becomes

    # disallow uploads for anonymous users
    #--anonymouscantupload

    Save it, chattr +i it, restart the FTP server, and you should be fine.

    cPanel.net Support Ticket Number:
     
  6. thedavid

    thedavid Well-Known Member

    Joined:
    Nov 22, 2002
    Messages:
    124
    Likes Received:
    0
    Trophy Points:
    16
    Annette,

    Thank you for your help - it still doesn't work but it at least has an easier error code to work with:

    Command: STOR test1231.txt
    Response: 553 Can't open that file: Permission denied

    I'll have to double check the permissions, etc..

    -David

    cPanel.net Support Ticket Number:
     
  7. thedavid

    thedavid Well-Known Member

    Joined:
    Nov 22, 2002
    Messages:
    124
    Likes Received:
    0
    Trophy Points:
    16
    Ok, it's still broken. I can't get anon to work on any of the servers - always this error. All the permissions look correct. Anyone have any ideas?

    cPanel.net Support Ticket Number:
     
  8. zye

    zye Well-Known Member

    Joined:
    Dec 6, 2002
    Messages:
    96
    Likes Received:
    1
    Trophy Points:
    8
    here same problem

    tried it also with the configuration edits but no luck

    a solution for this problem is needed

    thx
    zye

    cPanel.net Support Ticket Number:
     
  9. smiles

    smiles Registered

    Joined:
    Sep 18, 2003
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Still having this problem as well...have tried many things to no avail....

    Thanks!

    cPanel.net Support Ticket Number:
     
  10. X-Istencedotcom

    X-Istencedotcom Well-Known Member

    Joined:
    Apr 14, 2003
    Messages:
    223
    Likes Received:
    0
    Trophy Points:
    16
    Isnt it that you cant do anon FTP with pure-ftpd unless the user has his own dedicated IP?

    cPanel.net Support Ticket Number:
     
  11. smiles

    smiles Registered

    Joined:
    Sep 18, 2003
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    This is from the pure-ftpd docs...if it helps at all...

    * Anonymous FTP with virtual users.

    -> I successfully created a virtual user called 'ftp' or 'anonymous', but
    anonymous FTP doesn't work.

    Pure-FTPd never fetch any info from the virtual users backends (puredb,
    MySQL, LDAP, etc) for anonymous sessions. There are three reasons not to do
    so: - Speed: do we need to query a database just to get the anonymous
    user's home directory? We don't need to retrieve any password for anonymous
    sessions.
    - Consistency: with the virtual hosting mechanism.

    To run an anonymous FTP server you must have a *system* account called
    'ftp'. Don't give it any valid shell, just a home directory. That home
    directory is the anonymous area.
     
Loading...

Share This Page