The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Anonymous FTP Not Working

Discussion in 'General Discussion' started by Jeff75, Aug 4, 2003.

  1. Jeff75

    Jeff75 Well-Known Member

    Apr 11, 2003
    Likes Received:
    Trophy Points:
    I am running Proftpd 1.3.28 on FreeBSD 4.7 and have Anonymous FTP enabled in WHM under Tweak FTP and I also have it enabled on the account in cPanel. Each account has a dedicated IP address and it keeps coming up with a 530 Login Incorrect error whenever I try to connect using anonymous or as the username.

    I have also removed the comments from the anonymous ftp section in the proftpd.conf file. Does anybody have any idea why it's not allowing me to connect? Here are my settings for anonymous in the config file: Support Ticket Number:
  2. HostIt

    HostIt Well-Known Member

    Feb 22, 2003
    Likes Received:
    Trophy Points:
    I just went through much the same situation with a Ded.IP account that could not log on to Anon FTP without using "" as the username.

    It turns out that account was missing a VirtualHost entry in proftpd.conf. I added the entry and restarted FTP via WHM but it was still not working. I then manually restarted FTP in shell and it finally worked :)

    The moral: a) Make sure the VirtualHost entry exists in proftpd.conf and then b) Restart proftpd via SSH, because restarting it via WHM does not pick up changes in proftpd.conf.

    # /etc/rc.d/init.d/proftpd stop
    # /etc/rc.d/init.d/proftpd start
    #2 HostIt, Oct 23, 2003
    Last edited: Oct 23, 2003

Share This Page