The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Anonymous FTP not working

Discussion in 'General Discussion' started by carock, Mar 17, 2003.

  1. carock

    carock Well-Known Member

    Joined:
    Sep 25, 2002
    Messages:
    232
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    St. Charles, MO
    We're runing WHM 6.0.0 Cpanel 6.0.0-S109 RedHat 7.3 - WHM Xskin v 1.5

    I was showing a customer hwo to use Cpanel, and I clicked on the allow anonymous FTP box and saved.

    I tried loggin in as anonymous, and kept getting this error.

    530-Unable to set anonymous privileges.
    530 Login incorrect.
    ftp: Login failed.

    I'm using the proftpd daemon too.

    From the WHM in the tweak ftp settings link, this is also displayed.
    Anonymous Ftp is currently: enabled

    Any ideas?

    Thanks,
    Chuck
     
  2. ThunderHostingDotCom

    ThunderHostingDotCom Well-Known Member

    Joined:
    Nov 18, 2002
    Messages:
    450
    Likes Received:
    1
    Trophy Points:
    16
    Location:
    All over!

    I have the same problem and no one seems to know how to fix it.

    cPanel.net Support Ticket Number:
     
  3. carock

    carock Well-Known Member

    Joined:
    Sep 25, 2002
    Messages:
    232
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    St. Charles, MO
    Make sure you only have one anonymous FTP server per IP address on the machine.

    IF not, then you have to log in with anonymous_username@domain.com or something goofy like that.

    Allowing only anonymous and E-mail address as the password required a unique IP for the anonymous FTP site.

    Chuck

    cPanel.net Support Ticket Number:
     
  4. ThunderHostingDotCom

    ThunderHostingDotCom Well-Known Member

    Joined:
    Nov 18, 2002
    Messages:
    450
    Likes Received:
    1
    Trophy Points:
    16
    Location:
    All over!
    ================

    Ok, I tried something to test this out. I turned on Anonymous FTP for an account that has a dedicated IP. (It is also setup as a reseller so it has its own name servers) I get the below message when I try to enter the root URL ftp://webworkst.com or the upload URL ftp://webworkst.com/incoming. Why do I get this message?

    FTP proxy warning
    The folder 'ftp://webworkst.com/' is read-only because the proxy server is not setup to allow full access.
    To move, paste, rename, or delete files, you must use a different proxy. For information on changing your proxy, contact your administrator.

    Also, as you can see the welcome message is listed in the root ftp://webworkst.com as welcome.msg. When you click on it, it starts to download it. All FTP servers that I have seen have the welcome message post right on the main page or popup in another window. Why is mine like this?

    After all this I STILL can't upload files using IE. I tried to copy a simple txt file and past it into the browser window (both root & incoming) & the paste option is grayed out.

    Now I even FTP'd in and uploaded the test.txt file to both root & incoming under public_ftp. I can see the welcome.msg in the root & I even opened it & it says test in it just like I set it up to. When I go & refresh the browser it shows up fine in root but does not show up in incoming.

    What do I need to do to fix this darn Anonymous FTP?????

    cPanel.net Support Ticket Number:
     
Loading...

Share This Page