The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Anonymous FTP Problem

Discussion in 'General Discussion' started by polarbear541, Jun 12, 2007.

  1. polarbear541

    polarbear541 Registered

    Joined:
    Jun 12, 2007
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    I use cPanel on heliohost.org however when I make an Anonymous FTP account all i get when I log on is a folder names 'pub'. Even when there are files in the 'public_ftp' directory. Can anyone help? :confused:

    P.s. My host does not provide any cPanel Support!

    Edit: With normal new FTP accounts it just won't let you login.
     
    #1 polarbear541, Jun 12, 2007
    Last edited: Jun 12, 2007
  2. polarbear541

    polarbear541 Registered

    Joined:
    Jun 12, 2007
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    FTP Problem

    Hello? anyone there? :eek:
     
  3. useradmin

    useradmin Well-Known Member

    Joined:
    Oct 8, 2004
    Messages:
    107
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    INDIA
    anonymous

    same problem any help?
     
  4. linux-image

    linux-image Well-Known Member

    Joined:
    Jun 8, 2004
    Messages:
    1,192
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    India
    cPanel Access Level:
    Root Administrator
    this is what I get :

    [root@niKx ~]# ftp 64.235.55.113
    Connected to 64.235.55.113 (64.235.55.113).
    220---------- Welcome to Pure-FTPd [TLS] ----------
    220-You are user number 3 of 50 allowed.
    220-Local time is now 22:37. Server port: 21.
    220-IPv6 connections are also welcome on this server.
    220 You will be disconnected after 15 minutes of inactivity.
    Name (64.235.55.113:root): anonymous
    230 Anonymous user logged in
    Remote system type is UNIX.
    Using binary mode to transfer files.
    ftp> ls
    227 Entering Passive Mode (64,235,55,113,230,146)
    150 Accepted data connection
    drwxr-xr-x 3 32004 32004 4096 Mar 14 2007 .
    drwxr-xr-x 3 32004 32004 4096 Mar 14 2007 ..
    drwxr-xr-x 2 32004 32004 4096 Mar 14 2007 incoming
    226-Options: -a -l
    226 3 matches total
    ftp> cd incoming
    250 OK. Current directory is /incoming
    ftp> ls
    227 Entering Passive Mode (64,235,55,113,115,0)
    150 Accepted data connection
    drwxr-xr-x 2 32004 32004 4096 Mar 14 2007 .
    drwxr-xr-x 3 32004 32004 4096 Mar 14 2007 ..
    226-Options: -a -l
    226 2 matches total
    ftp>
    -----------------------------------------------------------------------------------------------
     
  5. npadgett

    npadgett Registered

    Joined:
    Aug 13, 2008
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Similar issues here... I Disabled Anonymous FTP in WHM, but can still ftp in anonymously. All i see is a "pub" folder that i can't do anything with. Also, when i create new accounts in WHM, the user of the account can FTP perfectly fine; but when i create ftp accounts using that account, i am unable to login with those newly created accounts.

    I've tried the username, full username, ip, ftp.DOMAIN.com and nothing works. It just says incorrect login.
     
  6. gkgcpanel

    gkgcpanel Well-Known Member

    Joined:
    Jun 6, 2007
    Messages:
    217
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    DataCenter Provider
    Having the same issue...

    We have anonymous FTP turned off on a server. If you try to connect to the host address via anonymous, it fails and says it's not allowed, and same for the IP address. However, if you go to one of the sites hosted on the server and ftp the domainname.tld with anonymous, it lets you connect but you can't do anything.

    It should not allow a connection at all... This particular server must be HIPPA compliant and right now isn't because anonymous FTP is allowed to connect and should not be.

    Any ideas why it is letting anonymous users connect when anonymous FTP has been turned off on the server???
     
  7. sirdopes

    sirdopes Well-Known Member
    PartnerNOC

    Joined:
    Sep 25, 2007
    Messages:
    141
    Likes Received:
    0
    Trophy Points:
    16
    Check the file /etc/pure-ftpd.conf and look for the following line.

    NoAnonymous yes


    Make sure it is set to yes and that will disable anonymous ftp logins.
     
  8. gkgcpanel

    gkgcpanel Well-Known Member

    Joined:
    Jun 6, 2007
    Messages:
    217
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    DataCenter Provider
    Checked that, and it is set. Still letting us connect (although we can't do anything)...
     
  9. cPanelJared

    cPanelJared Technical Analyst
    Staff Member

    Joined:
    Feb 25, 2010
    Messages:
    1,842
    Likes Received:
    18
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    If you are the server administrator (if you have root access to the WebHost Manager), please submit a ticket, and we will be happy to look at this for you. When you submit a ticket, you will be prompted for a support access number. This is listed in the WebHost Manager in Main >> Support >> Support Center.
     
Loading...

Share This Page