The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Anonymous ftp uploads

Discussion in 'General Discussion' started by donbonner, Mar 13, 2003.

  1. donbonner

    donbonner Member

    Joined:
    Feb 12, 2003
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    I'm getting error 553 Anonymous users may not overwrite existing files.

    How do I fix this error message. There are not files that are being overwritten
     
  2. qbert

    qbert Member

    Joined:
    Mar 13, 2003
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    You still having better luck than i am

    How did you get the anonymess ftp to work? i have been unable to do so :(

    Thanks

    Q
     
  3. Donna

    Donna BANNED

    Joined:
    Feb 15, 2003
    Messages:
    88
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Toronto, Canada
    try chmod'ing the upload directory to 666 (read write for all groups but no execute commands).
     
  4. parhelic

    parhelic Well-Known Member

    Joined:
    Oct 27, 2002
    Messages:
    47
    Likes Received:
    0
    Trophy Points:
    6
    Sorry, this doesnt appear to be the solution. Chmod'ing the public_ftp/incoming folder to 666 prevents the anonymous user from even entering this folder and returns Permission denied
     
  5. ThunderHostingDotCom

    ThunderHostingDotCom Well-Known Member

    Joined:
    Nov 18, 2002
    Messages:
    450
    Likes Received:
    1
    Trophy Points:
    16
    Location:
    All over!
    I have had the same problems. I also have no welcome message showing up. The below is what I was told to fix these errors. Hope this helps. If it does can you please tell me what you did exactly to fix it. Thank you.

    1) Fix1 for Anonymous FTP errors:
    Try switching to pureftp this is known to be better with the issues you are having.

    2) Fix2 for Anonymous FTP errors:
    Check and see if your other ips are in your /etc/pure-ftp dir

    3) Fix3 for Anonymous FTP errors:
    A. To add a virtual FTP server, you only need to create a symbolic link in /etc/pure-ftpd/ from the virtual host IP to the directory that contains the file for that virtual host.

    Example:
    ln -s /home/customers/rtchat.com/ftp /etc/pure-ftpd/216.226.17.77
    ln -s /home/customers/c9x.org/ftp /etc/pure-ftpd/212.73.209.252

    Q. Do I have to do this manually EVERY time I want to setup An. FTP on an account? I hope not.

    4) Fix for the welcome message not showing up:
    A. The welcome message is either in .banner or welcome.msg create a .banner file in the root of your ftp.
    Q. What is the path to these files?

    cPanel.net Support Ticket Number:
     
  6. ThunderHostingDotCom

    ThunderHostingDotCom Well-Known Member

    Joined:
    Nov 18, 2002
    Messages:
    450
    Likes Received:
    1
    Trophy Points:
    16
    Location:
    All over!
    1) Ok, I tried something to test this out. I turned on Anonymous FTP for an account that has a dedicated IP & has never had Anonymous FTP turned on for this domain. (It is also setup as a reseller so it has its own name servers) I get the below message when I try to enter the root URL ftp://webworkst.com or the upload URL ftp://webworkst.com/incoming. Why do I get this message?

    FTP proxy warning
    The folder 'ftp://webworkst.com/' is read-only because the proxy server is not setup to allow full access.
    To move, paste, rename, or delete files, you must use a different proxy. For information on changing your proxy, contact your administrator.

    After all this I STILL can't upload files using IE. I tried to copy a simple txt file and past it into the browser window (both root & incoming) & the paste option is grayed out.

    Now I even FTP'd in and uploaded the test.txt file to both root & incoming under public_ftp. I can see the welcome.msg in the root & I even opened it & it says test in it just like I set it up to. When I go & refresh the browser it shows up fine in root but does not show up in incoming.

    2) Also, as you can see the welcome message is listed in the root ftp://webworkst.com as welcome.msg. When you click on it, it starts to download it. All FTP servers that I have seen have the welcome message posted right on the main page or popup in another window. Why is mine like this?

    What do I need to do to fix this darn Anonymous FTP?????
     
    #6 ThunderHostingDotCom, Jun 16, 2003
    Last edited: Jun 16, 2003
  7. Website Rob

    Website Rob Well-Known Member

    Joined:
    Mar 23, 2002
    Messages:
    1,506
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    Alberta, Canada
    cPanel Access Level:
    Root Administrator
    May I point out the obvious?

    Setting up Anonymous FTP is like putting another "hole in your head". It is not required and can be very dangerous. ;)

    Understanding that 'anonymous' means 'anybody', why would someone want a setup where 'anybody' can upload files to their Web account? Much better to have 'anonymous' turned off and either; provide an upload script/page if neccessary or give FTP access to certain individuals only.

    Just a thought.

    cPanel.net Support Ticket Number:
     
Loading...

Share This Page