The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Anonymous FTP

Discussion in 'General Discussion' started by Slav, Feb 7, 2004.

  1. Slav

    Slav Well-Known Member

    Joined:
    Oct 28, 2002
    Messages:
    144
    Likes Received:
    0
    Trophy Points:
    16
    Ok i hope this can get some answers for me as i read all the stuff on this topic but nothing stands out to fix all my issues.

    Anyway i have a trouble ticket with the following.

    "I am having trouble getting anonymous FTP to work in the accounts of my clients. one of my clients has uploaded several files to their public_ftp directory, but are unable to access them via anonymous FTP (the files don't appear in the file window). CPanel is set up to allow anonymous FTP on all accounts. Anonymous FTP on the main reseller account works fine. Any help would be appreciated."

    We run Pure Ftp and anonymous is enabled to work.
    Now i personally could upload the files to another server and it all worked all okay.
    Now on this server i done the same with my normal account full login i uploaded the file and then tried accessing the folder via the anonymous and and anonymous@domain.com which both times logged me in but all i could see was the incoming folder.
    I could not even see the welcome message being displayed like on the oher servers it does after creating it.

    We run

    WHM 8.5.1 cPanel 8.5.3-S3
    RedHat - WHM X v2.1.1

    On all the servers.

    Any help would be great. Thanks in advance.

    Slav
     
    #1 Slav, Feb 7, 2004
    Last edited: Feb 7, 2004
  2. DHL

    DHL Well-Known Member

    Joined:
    Mar 8, 2002
    Messages:
    88
    Likes Received:
    0
    Trophy Points:
    6
    /etc/sysconfig/pure-ftpd needs to be edited to allow anonymous uploads. The ftp server needs to be restarted after this change.

    Also the public_ftp/incoming directory needs a permissions/owner change, then you will be able to use anonymous ftp with pure-ftpd np.

    Let me know should you need any further help :)
     
  3. Slav

    Slav Well-Known Member

    Joined:
    Oct 28, 2002
    Messages:
    144
    Likes Received:
    0
    Trophy Points:
    16
    Thanks i checked on 2 servers and they both have the same info in that file as

    # Do not allow anonymous access:
    #--noanonymous

    # Opposite of the above: Allow anonymous access only:
    #--anonymousonly

    # disallow uploads for anonymous users
    --anonymouscantupload


    So this says that anonymous access is allwed and the uploading is not which is fine for the uploading part.

    As i say this is exactly on that server and another but one shows the files and the other does not weird.
     
  4. DHL

    DHL Well-Known Member

    Joined:
    Mar 8, 2002
    Messages:
    88
    Likes Received:
    0
    Trophy Points:
    6
     
  5. damainman

    damainman Well-Known Member

    Joined:
    Nov 13, 2003
    Messages:
    515
    Likes Received:
    0
    Trophy Points:
    16
    Quick question thats off topic:

    When you disable anonymous ftp via WHM, does it disable it for all your clients or no?

    Any pros or cons using anny ftp with pureftp?
     
  6. Slav

    Slav Well-Known Member

    Joined:
    Oct 28, 2002
    Messages:
    144
    Likes Received:
    0
    Trophy Points:
    16
    What permison i set it to? The incoming folder? 666 ?
     
  7. phpman

    phpman Well-Known Member

    Joined:
    Sep 3, 2003
    Messages:
    50
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Rio de Janeiro - Brazil
    FTP Anonimous per account

    For default Cpanel just creates an only anonymous ftp for server that is in /var/ftp

    To supply the anonymous ftp for account you should make an inclusion in the conf of the proftpd.


    edit: /etc/proftpd.conf

    ---x---x---x---x---x---x---x---


    pico -w /etc/proftpd.conf

    At the end of the file it includes:

    -------------------------------------------
    <VirtualHost 66.98.193.150> ######## alter the number IP
    ExtendedLog /etc/httpd/domlogs/ftp.svclub.com.br-ftpbytes_log READ BytesLog ######## alter the domlogs
    TransferLog /etc/httpd/domlogs/ftp.svclub.com.br-ftp_log ######## alter the domlogs
    ServerName ftp.svclub.com.br ######## alter the host
    AuthUserFile /etc/proftpd/svclub ######## alter the file of conf
    MaxClients 3 "Sorry, this ftp server has reached its maximum user count (%m). Please try again later"
    DirFakeGroup On ftpgroup
    DirFakeUser On ftpuser
    DefaultRoot ~
    <Directory />
    AllowOverwrite on
    HideGroup wheel
    HideUser root
    </Directory>
    <Anonymous /home/svclub/public_ftp> ########################################### alter the path
    UseFtpUsers on
    RequireValidShell off
    UseFtpUsers on
    RequireValidShell off
    User ftp
    Group ftp
    UserAlias anonymous ftp
    DisplayLogin welcome.msg
    DisplayFirstChdir .message
    <Limit WRITE>
    DenyAll
    </Limit>
    <Directory incoming>
    <Limit STOR>
    AllowAll
    </Limit>
    <Limit WRITE READ>
    DenyAll
    </Limit>
    </Directory>
    </Anonymous>
    </VirtualHost>
    -------------------------------------------


    Save, exit and restart service

    ctrl + o
    ctrl + x
    service proftpd restart


    Huggs
     
  8. mweb

    mweb Member

    Joined:
    Mar 11, 2003
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    1
    arrrgh...
    I'm trying to get pure-ftp working for anonymous.

    I've got:
    AnonymousOnly no
    NoAnonymous no
    AnonymousCanCreateDirs no
    #AnonymousRatio 1 10
    AnonymousCantUpload no

    I've set the following perms to eliminate issues:
    /home/userdir/public_ftp 777
    /home/userdir/public_ftp/incoming 777
    /home/userdir/public_ftp/incoming/subdir 777

    And I consistently get:
    553 Anonymous users may not overwrite existing files

    help?
     
  9. jeroman8

    jeroman8 Well-Known Member

    Joined:
    Mar 14, 2003
    Messages:
    410
    Likes Received:
    0
    Trophy Points:
    16
    Ok, I'm having the same problem !

    I use Pure_FTP

    What I can see is if I just check the anonymous login box in the FTP client I go to a directory NOT related to the domain I use in the address.

    If I unmark the anonymous login box in ftp klient and write the username anonymous, I'm going to the correct domains public_ftp folder BUT i can not upload anything, I get:

    553 anon... users not allowed to owerwrite files.

    I can download the files in there that was uploade using the regular account and chmod 777.
     
  10. phpman

    phpman Well-Known Member

    Joined:
    Sep 3, 2003
    Messages:
    50
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Rio de Janeiro - Brazil
    Sorry;

    Anonimouys FTP not Working em Pure Ftp
     
  11. equens

    equens Well-Known Member

    Joined:
    Feb 8, 2002
    Messages:
    270
    Likes Received:
    0
    Trophy Points:
    16
    pico /etc/sysconfig/pure-ftpd

    comment --anonymouscantupload

    # disallow uploads for anonymous users
    # --anonymouscantupload

    Save and restart

    /etc/rc.d/init.d/pure-ftpd restart

    Good Look
     
Loading...

Share This Page