Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

another cPanel + AWStats bug

Discussion in 'General Discussion' started by dendis, Mar 2, 2005.

  1. dendis

    dendis Well-Known Member

    Joined:
    Jul 18, 2003
    Messages:
    49
    Likes Received:
    0
    Trophy Points:
    156
    At the end of the month I have removed all log files from /usr/local/apache/domlogs/*

    Restarted cpanel. It looks like it processed logs. Now when you try to update any domain AWStats get error:
    Error: LogFile parameter is not defined in config/domain file

    Setup ('/home/anyuser/tmp/awstats/awstats.anydomain.com.conf' file, web server or permissions) may be wrong.
    Check config file, permissions and AWStats documentation (in 'docs' directory).

    I check '/home/anyuser/tmp/awstats/awstats.anydomain.com.conf' and I see:
    LogFile=""

    Now can someone tell me why first of whole '/home/anyuser/tmp/awstats/awstats.anydomain.com.conf' has been modified/recreated

    And secondly do now we have to go and edit every user awstats config file?? I would be nightmare to fix it.

    Manually fix would be edit conf file and change LogFile="" to LogFile="/usr/local/apache/domlogs/anydomain.con"

    Any ideas ??
     
  2. dendis

    dendis Well-Known Member

    Joined:
    Jul 18, 2003
    Messages:
    49
    Likes Received:
    0
    Trophy Points:
    156
    BTW /usr/local/cpanel/etc/awstats.conf has LogFile="%LOGFILE%"
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice