The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Another EXIM error

Discussion in 'General Discussion' started by oSM, Dec 8, 2001.

  1. oSM

    oSM Well-Known Member

    Joined:
    Aug 18, 2001
    Messages:
    46
    Likes Received:
    0
    Trophy Points:
    6
    One of my users keep getting this.. Anyone know how to resolve this. I delete his account and re-install everything.. The problem still exists..

    Basically, he CANNOT receive ANY emails to his POP3 account called Allen.


    ==============
    This message was created automatically by mail delivery software (Exim).

    A message that you sent could not be delivered to one or more of its
    recipients. This is a permanent error. The following address(es) failed:

    allen@doms30.com
    Permission denied:
    creating lock file hitching post /home/doms30/mail/allen/inbox.lock.box1.myhostingco.com.3c10a4a7.00000e92 (euid=52761 egid=12):
    retry timeout exceeded


    [Edited on 12/8/01 by oSM]
     
  2. feanor

    feanor Well-Known Member

    Joined:
    Aug 13, 2001
    Messages:
    836
    Likes Received:
    0
    Trophy Points:
    16
    Permissions.
    Wipe out lock files server-wide, and run /scripts/mailperm ....

    Make sure /var/spool/exim permissions aren\'t funky either.
     
  3. oSM

    oSM Well-Known Member

    Joined:
    Aug 18, 2001
    Messages:
    46
    Likes Received:
    0
    Trophy Points:
    6
    FEANOR... THANKS FOR YOUR HELP!!!
    I will try it soon.. BTW:

    >Make sure /var/spool/exim permissions aren\'t funky either.

    How do I check whether they are funky or not? lol
    What permission should they be on? :)
     
  4. feanor

    feanor Well-Known Member

    Joined:
    Aug 13, 2001
    Messages:
    836
    Likes Received:
    0
    Trophy Points:
    16
    This is normal and functional:
    (for /var/spool/exim)

    ........................
    total 288
    drwxr-x--- 5 root root 4096 Nov 10 15:09 ./
    drwxrwxr-x 4 root root 4096 Nov 5 08:52 ../
    drwxr-x--- 2 root root 4096 Nov 10 22:18 db/
    -rw-r--r-- 1 root root 6 Nov 28 18:28 exim-daemon.pid
    drwxr-x--- 2 root root 188416 Dec 8 12:46 input/
    drwxr-x--- 2 root root 81920 Dec 8 12:46 msglog/
    ........................
     
  5. oSM

    oSM Well-Known Member

    Joined:
    Aug 18, 2001
    Messages:
    46
    Likes Received:
    0
    Trophy Points:
    6
    problem still occurs..
    Even after I delete his entire account and resetup it up again.. the problem just occurs again... :(
    anyone got ideas?
     
  6. feanor

    feanor Well-Known Member

    Joined:
    Aug 13, 2001
    Messages:
    836
    Likes Received:
    0
    Trophy Points:
    16
    Show me permission output and I will be able to decipher the problem. Is the domain in localdomains / valiases / userdomains ??
     
  7. oSM

    oSM Well-Known Member

    Joined:
    Aug 18, 2001
    Messages:
    46
    Likes Received:
    0
    Trophy Points:
    6
    Hi, thanks for your help feanor!
    The domain is in the localdomains, valiases and userdomains.

    This is what my /var/spool/exim directory shows:

    total 48
    drwxr-x--- 5 root root 4096 Sep 24 17:10 ./
    drwxr-xr-x 13 root root 4096 Sep 4 22:13 ../
    drwxr-x--- 2 root root 4096 Sep 25 00:01 db/
    -rw-r--r-- 1 root root 5 Dec 11 21:06 exim-daemon.pid
    -rw-r----- 1 root nobody 5466 Dec 11 04:00 exim-process.info
    drwxr-x--- 2 root root 16384 Dec 11 21:09 input/
    drwxr-x--- 2 root root 8192 Dec 11 21:09 msglog/

    Also, I have noticed that for every 100 emails that get sent out. About 10 will not get to their intended destination. We get NO bounce back, relay problems, nothing. The receiver just NEVER gets the email.
     
  8. Hades

    Hades Member

    Joined:
    Jan 15, 2004
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    they are stuck in the queue arn't they?

    having these same issues and getting mad now, its the lock files but i don;t know what going on.
     
  9. SarcNBit

    SarcNBit Well-Known Member

    Joined:
    Oct 14, 2003
    Messages:
    1,010
    Likes Received:
    3
    Trophy Points:
    38
    I am not sure if you took notice before posting, but this thread has been inactive for over 2 years.

    Many changes have been made to cPanel in the last two years.
     
Loading...

Share This Page