AntiRelayd...Please Help!!!


Well-Known Member
Jun 8, 2002
Let me rephrase my statement:

This feature is enabled by default.

Should be:

This feature is enabled by default in Tweak Settings.

Meaning: this feature is only enabled if you go into Tweak Settings after the upgrade to 11.23 and save the Tweak Settings without unticking the boxes for the Proxy access feature.

If no subdomain exists for a webmail A record (or cpanel, whm, etc) that record will be over-written.
Why are we once again setting new features to enabled for existing installs? All this does is break expected behavior with your customers. New features should always be set to off by default and when the customer is ready for them, they can turn it on.

[added] More about what I mean is that the tweak settings page is getting pretty large these days with a ton of settings. Its no longer easy to tell when there is a new setting on the page and simply having a few tiny **'s on the line doesn't really catch one's eye expecially if someone is trying to make a quick change in tweak settings. If you're going to force new settings to be enabled by default on the user, you should do a much better job of conveying that once they save the page, this will have a major change on its configuration. If you were to color code the setting based on its impact (such as red for the proxy), or put up a notice saying there are new settings and what they do to make sure they're properly set before saving, that may help prevent people from making unintended changes to their settings.

I still think that the best solution is new settings should only be set to on when the user actually goes and turns it on though.

Last edited:


Well-Known Member
Jun 1, 2002
cPanel Access Level
Root Administrator
I can longer get AntiRelayd to restart and it will NOT write my alwaysrelay hosts file to relayhosts.

I just recently had this issue after upgrading to Current, but just on one of my servers.

For some reason, IPs were not being written to the relayhosts file anymore. Or relayhostsusers.

Even after resetting Exim Config using default ACLs, still had a problem. Authenticated users were not being logged.

Eventually, I went to Service Manager and though tailwatchd was enabled, I also turned on 'monitor' for it. Save, and poof, IPs are being logged again.

I'm not sure what fixed it, what caused the issue in the first place (besides updating), but all is good now.