Gareth-AWD

Well-Known Member
Jul 3, 2008
195
13
68
London, UK
cPanel Access Level
Root Administrator
Our server had a power outage and on return Antirelayd has failed. I know it's not recommended but we have lots of customers who have this set up to only use their outgoing mail this way.

When I try to enable via Tailwatchd it says this

Failed to load Cpanel::Tailwatch::antirelayd1: at /usr/local/cpanel/Cpanel/TailWatch/Utils/EnableDisable.pm line 25.

The command I'm running is

/usr/local/cpanel/bin/tailwatchd --enable=Cpanel::Tailwatch::antirelayd1

Ideas?
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,227
463
New Didn't help. I can't seem to enable it. It's ticked in the settings.
Hello :)

Here's additional information from the 11.52 release notes:

antirelayd renamed to popbeforesmtp
The antirelayd function allows users on an IP address who authenticated against the POP3 or IMAP service in the last 30 minutes to send emails via SMTP again without the need to re-authenticate. This leaves the IP address open as a relay, which poses a security risk.

In cPanel & WHM version 11.52, we made the following changes to this function:

  • We changed the name of the antirelayd function to popbeforesmtp(POP-before-SMTP).
  • This function defaults to disabled.
  • We moved the configuration of this option from WHM's Service Manager interface to the Allow users to relay mail if they use an IP address through which someone has validated an IMAP or POP3 login within the last hour (Pop-before-SMTP) option in the Mail section of WHM's Tweak Settings - Mail interface (Home >> Server Configuration >> Tweak Settings).
Previously, in cPanel & WHM version 11.32, we deprecated this function and set it to disabled by default because most mail clients support SMTP authentication. However, some users of legacy email clients require it.

We strongly recommend that you use SMTP authentication instead of POP-before-SMTP authentication, and encourage your users to only use mail clients that support SMTP authentication.
To clarify, did you enable the option in "WHM >> Tweak Settings"?

Thank you.