any update about ea-PHP 7.4 under CloudLinux ?

bejbi

Well-Known Member
PartnerNOC
Jan 20, 2006
137
22
168
Poland
cPanel Access Level
DataCenter Provider
Thank you.

But I need little help:

yum update ea-php74* ea-profiles-cpanel

shows:
Packets ea-php74* are available, but not installed
No packages marked for update

when I try:
yum install ea-php74* ea-profiles-cpanel

I have list of many packages, but:

Error: ea-apache24-mod_mpm_prefork conflicts with 1:ea-apache24-mod_http2-2.4.43-2.el7.cloudlinux.x86_64
Error: ea-apache24-mod_mpm_event conflicts with 1:ea-apache24-mod_mpm_prefork-2.4.43-2.el7.cloudlinux.x86_64
Error: ea-apache24-mod_mpm_event conflicts with 1:ea-apache24-mod_cgi-2.4.43-2.el7.cloudlinux.x86_64
Error: ea-apache24-mod_cgi conflicts with 1:ea-apache24-mod_cgid-2.4.43-2.el7.cloudlinux.x86_64
Error: ea-apache24-mod_mpm_prefork conflicts with 1:ea-apache24-mod_mpm_event-2.4.43-2.el7.cloudlinux.x86_64
Error: ea-apache24-mod_cgi conflicts with 1:ea-apache24-mod_mpm_event-2.4.43-2.el7.cloudlinux.x86_64
Error: ea-apache24-mod_mpm_prefork conflicts with 1:ea-apache24-mod_cgid-2.4.43-2.el7.cloudlinux.x86_64
Error: ea-apache24-mod_cgid conflicts with 1:ea-apache24-mod_cgi-2.4.43-2.el7.cloudlinux.x86_64
Error: ea-apache24-mod_cgid conflicts with 1:ea-apache24-mod_mpm_prefork-2.4.43-2.el7.cloudlinux.x86_64
Error: ea-apache24-mod_http2 conflicts with 1:ea-apache24-mod_mpm_prefork-2.4.43-2.el7.cloudlinux.x86_64

How to install ea-PHP74 ?
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,296
1,252
313
Houston
You can not update packages you do not have installed. In order to use ea-php74 you'd need to install it. So I'm unsure why you'd be trying to update it.

The conflicts you're getting when attempting to install the ea-php74 packages is a result of what looks to be conflicting packages. You can't install ea-php with a wildcard like this. Looking at this list some serious problems strike me:

1. You've attempted to install multiple MPM's which is not possible.
Code:
Error: ea-apache24-mod_mpm_event conflicts with 1:ea-apache24-mod_mpm_prefork-2.4.43-2.el7.cloudlinux.x86_64
Error: ea-apache24-mod_mpm_prefork conflicts with 1:ea-apache24-mod_mpm_event-2.4.43-2.el7.cloudlinux.x86_64
2. You've attempted to install MPM's that conflict with modules i.e., mod_http2 and prefork as well as modules that are not compatible with each other:
Code:
Error: ea-apache24-mod_mpm_prefork conflicts with 1:ea-apache24-mod_http2-2.4.43-2.el7.cloudlinux.x86_64
Error: ea-apache24-mod_mpm_event conflicts with 1:ea-apache24-mod_cgi-2.4.43-2.el7.cloudlinux.x86_64
Error: ea-apache24-mod_cgi conflicts with 1:ea-apache24-mod_cgid-2.4.43-2.el7.cloudlinux.x86_64
Error: ea-apache24-mod_cgi conflicts with 1:ea-apache24-mod_mpm_event-2.4.43-2.el7.cloudlinux.x86_64
Error: ea-apache24-mod_mpm_prefork conflicts with 1:ea-apache24-mod_cgid-2.4.43-2.el7.cloudlinux.x86_64
Error: ea-apache24-mod_cgid conflicts with 1:ea-apache24-mod_cgi-2.4.43-2.el7.cloudlinux.x86_64
Error: ea-apache24-mod_cgid conflicts with 1:ea-apache24-mod_mpm_prefork-2.4.43-2.el7.cloudlinux.x86_64
Error: ea-apache24-mod_http2 conflicts with 1:ea-apache24-mod_mpm_prefork-2.4.43-2.el7.cloudlinux.x86_64
 

bejbi

Well-Known Member
PartnerNOC
Jan 20, 2006
137
22
168
Poland
cPanel Access Level
DataCenter Provider
I did installed it already just via yum install ea-php74

I asked about installing with wildacd (*), becouse it was on cloudlinux blog given as suggested install precedure ...

Interesting is, that cPanel consultant on ticket also gave me wrong interpretation of this bug :) Yours is correct.
 

bejbi

Well-Known Member
PartnerNOC
Jan 20, 2006
137
22
168
Poland
cPanel Access Level
DataCenter Provider
Same here, I received some solutions by Cloudlinux but they didn't work.

I still don't see PHP 7.4 when trying to customize EasyApache profile.

Wished Cloudlinux and cPanel worked more together to avoid this.
Try:
1. yum install ea-php74
(there will be some dependencies - go ahead with them)
2. then go to easyapache - click "Customise" - there will be NO php 7.4
3. Go to "PHP extensions" tab and there will be php 7.4 - you can install modules which you need
4. Make provision

... and you will have ea-PHP 7.4 under CloudLinux
 

quietFinn

Well-Known Member
Feb 4, 2006
1,222
87
178
Finland
cPanel Access Level
Root Administrator
Try:
1. yum install ea-php74
(there will be some dependencies - go ahead with them)
2. then go to easyapache - click "Customise" - there will be NO php 7.4
3. Go to "PHP extensions" tab and there will be php 7.4 - you can install modules which you need
4. Make provision

... and you will have ea-PHP 7.4 under CloudLinux
I did the same, seems to be ok.
But of course this not how it's supposed to work.
 
  • Like
Reactions: bejbi

bejbi

Well-Known Member
PartnerNOC
Jan 20, 2006
137
22
168
Poland
cPanel Access Level
DataCenter Provider
@quietFinn - my opinion is the same: cPanel made php 7.4 only for pure cPanel. CloudLinux makes then compilation of this version with next delay.
.
But even when ea-php 7.4 is released by CL there is no information how exactly it should be installed - CL instruction doesn't work at all.
For now in my default profile ea-php 7.4 works, but formal is not visible in EA4 "PHP versions" tab ...

On next new server we decided to try implement only alt-php (no ea-php) - we will see if this will be better solution or not ...
 
Last edited:

Duplika

Well-Known Member
Feb 26, 2005
68
2
158
Buenos Aires, Argentina
cPanel Access Level
Root Administrator
Twitter
Yeah, we did the same. Started using Cloudlinux PHP selector on a new server, but I wished we could keep using cPanel's PHP for all servers.

If we migrate an account from one server using one PHP selector, to another server without it, we'd need to check for php.ini, .htaccess modifications and reconfigure it via cPanel.

Again, wished cPanel and Cloudlinux worked closer together to use the same selector, or at least don't hurt each other like it happens now.
 

Denis.v

Member
Jun 9, 2019
5
0
1
Ukraine
cPanel Access Level
Root Administrator
Hello.
Sorry, but I didn’t see the solution - how to display PHP 7.4 in the EA section (Current profile): EasyApache 4 --- Customize--- PHP Versions and install it from here, not from terminal, not using yum ..
@CloudLinux Skhristich, will it be possible, as it was with php7.3 and earlier?
 

CloudLinux Skhristich

Well-Known Member
Verifed Vendor
May 23, 2019
62
31
18
kiev
cPanel Access Level
Root Administrator
Hello.
Sorry, but I didn’t see the solution - how to display PHP 7.4 in the EA section (Current profile): EasyApache 4 --- Customize--- PHP Versions and install it from here, not from terminal, not using yum ..
@CloudLinux Skhristich, will it be possible, as it was with php7.3 and earlier?
Hello Denis,
To help you with this question we need a little bit more information, please create a ticket here https://cloudlinux.zendesk.com/hc/en-us/requests/new and technical experts will help you asap.