Any way to install "custom" modules (mod_qos, mod_reqtimeout) in EasyApache4?

tss

Member
Aug 22, 2011
13
3
53
Will this work using a custom profile? I see that mod_qos is disabled in Apache 2.4, but not in Apache 2.2. I'd also like to install mod-evasive and mod-spamhaus. I want to use EA4 to provide different PHP versions for different sites, and plan to use MPM-Event (or MPM-worker, if event won't work), but I'd also like to mitigate some of the DoS attacks the server has been experiencing. I'm looking at using a custom profile based on All PHP Options + OpCache.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,228
463
Hello :)

There are plans to add documentation on creating RPM packages with EasyApache 4 that showcases how to add custom modules, but there's no specific time frame available on that at this time.

Thank you.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,228
463
Any update on this? I can't for the life of me figure out how to install mod_qos or mod_evasive on my EasyApache4 deployment.
Hello,

The following page provides some information on building custom RPMs with EasyApache 4:

ea4.ninja

Thank you.