optize

Well-Known Member
Apr 27, 2005
145
0
166
I found a bug, well... according to cPanel, it's not a bug. Trying to figure out if it affects anyone but me.

Everytime you enable IPv6 on a customer account, it will change your outbound IPv6 IP to that customer's IPv6 IP.

To test (you need to have IPv6 already on the box)

- curl http://ipv6.ipplease.net (remember that IP)
- create a new cPanel account, enable IPv6 on that new account
- curl http://ipv6.ipplease.net

Did the IP's change? They do on all of my boxes, trying to figure out if it's the way we configure the primary IPv6 IP, or if this is a bug that cPanel refuses to acknowledge.

Thanks!
 

cPanelMichael

Technical Support Community Manager
Staff member
Apr 11, 2011
47,911
2,233
363
cPanel Access Level
DataCenter Provider
Twitter
Please open a support ticket so we can take a closer look:

Submit A Ticket

You can post the ticket number here so we can update this thread with the outcome.

It's important to keep in mind that we only support IPv6 for website content at this time. IPv6 support for sending and receiving email will come in a future release.

Thank you.
 

ChrisFirth

Active Member
PartnerNOC
Apr 10, 2008
35
0
56
cPanel Access Level
DataCenter Provider
Everytime you enable IPv6 on a customer account, it will change your outbound IPv6 IP to that customer's IPv6 IP.
I have not had a chance to play with IPv6 support yet, I will update my test server now and give it a go to verify what I'm saying below.

I suspect this happens if when an account has an IPv6 address assigned cPanel then binds the address to the server. When sending traffic out via IPv6 there is a selection algorithm that gets run to choose which address to send the traffic out via. If more than one address meets all the conditions then the one that was added last is picked.

Generally the fix for this is set "preferred_lft 0" when the address is bound so it is marked as deprecated and it will not be used for outgoing traffic unless it is replying to something sent to it. If you run 'ip a l' (assuming Linux), check to see if the IPv6 addresses have 'deprecated' next to them like this:

3: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
....
inet6 2400:8900::something/64 scope global deprecated
valid_lft forever preferred_lft forever
inet6 2400:8900::something2/64 scope global deprecated
valid_lft forever preferred_lft forever

If they don't, then its probably the selection algorithm doing it's job and picking the latest added address. If they do say deprecated something else is happening.

-----

Just tested it on my test cPanel server and I can confirm the same problem, assigning an IPv6 address to a user causes the server to use that IP as the outgoing address for IPv6, address is not deprecated.
 
Last edited:

bazzi

Well-Known Member
May 23, 2004
119
0
166
Same problem here. I also see that if you do
Code:
# service restart network
It loses al the IPv6 adresses in the ifconfig.