The Community Forums

Interact with an entire community of cPanel & WHM users.
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Apache 2.2 compatibility

Discussion in 'EasyApache' started by paszczak000, Apr 12, 2008.

  1. paszczak000

    paszczak000 Active Member

    Joined:
    Nov 29, 2007
    Messages:
    42
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Poland, Łódź
    Hello again.
    I'm preparing to upgrade Apache 1.3.41 ti Apache 2.2 using Easy::Apache v3.2.0 Build 4082. I have:
    WHM 11.15.0 cPanel 11.18.3-S21703
    CENTOS Enterprise 4.6 x86_64 on standard - WHM X v3.1.0
    Have anyone try this? How about compatibility with WHM, CPanel and scripts?
     
  2. callumw

    callumw Registered

    Joined:
    Apr 15, 2008
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Hi
    I know Hasweb use Apache 2.2.8 with their cPanel
    Also using PHP 5.2.5 and MySQL 5.0.45 too

    Hope that helps
     
  3. handsonhosting

    handsonhosting Well-Known Member

    Joined:
    Feb 17, 2002
    Messages:
    151
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Omaha, NE
    cPanel Access Level:
    Root Administrator
    We've run similar upgrades in the past with no issues. The only issues that we really ran into were 3rd party scripts that were not compatible with PHP5 and instead users would have to upgrade their scripts.

    If you have users using PHP scripts on the server, I'd advise getting a SECOND SERVER and then moving customers from one machine to the other as they approve the software changes. Doing a forced upgrade will likely break some scripts for customers, and then you've got a whole new bag of issues from your clients.

    I've done the upgrades on some machines where eCommerce and PHP Scripts were not in high production, and had no issues.
     
Loading...

Share This Page