Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Apache 2.2 : turn off Serversignature. version is still there

Discussion in 'EasyApache' started by gundamz, Jan 23, 2008.

  1. gundamz

    gundamz Well-Known Member

    Joined:
    Mar 27, 2002
    Messages:
    245
    Likes Received:
    0
    Trophy Points:
    316
    Apache 2.2 : turn off Serversignature. version is still there

    I have turn off serversignature.

    After restart, the apache version with the modules are still listed.

    any ideas why?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. bornonline

    bornonline Well-Known Member

    Joined:
    Nov 19, 2004
    Messages:
    139
    Likes Received:
    0
    Trophy Points:
    166
    Location:
    Earth
    Try this after you update the conf file.
    /usr/local/cpanel/bin/apache_conf_distiller --update --main

     
  3. gundamz

    gundamz Well-Known Member

    Joined:
    Mar 27, 2002
    Messages:
    245
    Likes Received:
    0
    Trophy Points:
    316
    I did run /usr/local/cpanel/bin/apache_conf_distiller --update --main and restart apache.

    It is still there.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. sampride

    sampride Member

    Joined:
    Jul 8, 2005
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    151
    you need to put the code at

    /etc/httpd/conf/extra/httpd-default.conf
     
  5. gundamz

    gundamz Well-Known Member

    Joined:
    Mar 27, 2002
    Messages:
    245
    Likes Received:
    0
    Trophy Points:
    316

    I edit that file and restart apache.

    It is still showing the version and other info.

    Did you successfully remove the version?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. arhs

    arhs Well-Known Member

    Joined:
    Jul 4, 2003
    Messages:
    116
    Likes Received:
    0
    Trophy Points:
    166
    Add this:

    Code:
    ServerSignature Off
    ServerTokens Prod
     
  7. gundamz

    gundamz Well-Known Member

    Joined:
    Mar 27, 2002
    Messages:
    245
    Likes Received:
    0
    Trophy Points:
    316
    I have already those in httpd.conf

    it is still showing apache version.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. sawbuck

    sawbuck Well-Known Member

    Joined:
    Jan 18, 2004
    Messages:
    1,366
    Likes Received:
    5
    Trophy Points:
    168
    cPanel Access Level:
    Root Administrator
    Assuming your directives are correct in /usr/local/apache/conf/extra/httpd-default.conf then add the following to httpd.conf:

    Include "/usr/local/apache/conf/extra/httpd-default.conf" and run the command bornonline mentioned.
     
  9. sampride

    sampride Member

    Joined:
    Jul 8, 2005
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    151

    Yes, I've disabled the signature in apache2
     
  10. rhenderson

    rhenderson Well-Known Member

    Joined:
    Apr 21, 2005
    Messages:
    785
    Likes Received:
    0
    Trophy Points:
    166
    Location:
    Oklahoma
    cPanel Access Level:
    Root Administrator
    Where is it showing the version from WHM or a phpinfo page? I thought I was not disabling the signature because it was showing in WHM Apache Status page, but loading phpinfo shows the signature is disabled.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  11. WebHostDog

    WebHostDog Well-Known Member

    Joined:
    Sep 3, 2006
    Messages:
    144
    Likes Received:
    1
    Trophy Points:
    166
    cPanel Access Level:
    Website Owner
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  12. gundamz

    gundamz Well-Known Member

    Joined:
    Mar 27, 2002
    Messages:
    245
    Likes Received:
    0
    Trophy Points:
    316
    I am viewing it from WHM > Apache status.

    I guess it had been disabled since phpinfo doesn't show it..

    WebHostDog, i tried that. It is not showing apache version.

    I think it is working fine.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  13. SuperBaby

    SuperBaby Well-Known Member

    Joined:
    Nov 27, 2003
    Messages:
    336
    Likes Received:
    0
    Trophy Points:
    166
    Location:
    Thailand
    cPanel Access Level:
    Website Owner
    Twitter:
    In Apache 2.x, you need to add this line to httpd.conf and restart Apache:

    SecServerSignature "Your String Here"
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice