The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Apache 2.x

Discussion in 'EasyApache' started by cyberspirit, Aug 4, 2003.

  1. cyberspirit

    cyberspirit BANNED

    Joined:
    Jun 27, 2003
    Messages:
    293
    Likes Received:
    0
    Trophy Points:
    0
    What is the reason that the current WHM/cpanel release uses an older Apache http server (1.3x) that is no longer developed and not the current one (2.x)?

    cPanel.net Support Ticket Number:
     
  2. casey

    casey Well-Known Member

    Joined:
    Jan 17, 2003
    Messages:
    2,303
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    If there is trouble, it will find me
    From Apache:
    Extensive changes were made to the server API in Apache 2.0. Existing modules designed for the Apache 1.3 API will not work in Apache 2.0 without modification.

    There's one major reason. What makes you say that 1.3 is no longer developed? There was a new release 2 weeks ago (1.3.28).

    cPanel.net Support Ticket Number:
     
  3. Jeff75

    Jeff75 Well-Known Member

    Joined:
    Apr 11, 2003
    Messages:
    555
    Likes Received:
    0
    Trophy Points:
    16
    Just because there's a 2.x is newer doesn't mean it's better. How many hosts do you really see who offer Apache 2.x (at least who know what they are doing)?

    cPanel.net Support Ticket Number:
     
  4. cyberspirit

    cyberspirit BANNED

    Joined:
    Jun 27, 2003
    Messages:
    293
    Likes Received:
    0
    Trophy Points:
    0
    Well, I got this here from the apache website:

    >>>>The Apache 1.3 series is being actively maintained, but not actively developed. Releases will be made to address security issues, or after a comfortable number of bug fixes have been made. New features will more than likely not be added to 1.3 in preference to 2.0.

    Use the Apache 1.3.28 version if you need to use third party modules that are not yet available as an Apache 2.0 module. Apache 1.3 is not compatibile with Apache 2.0 modules.<<<<

    So this means that 1.3 is not further developed but just maintained! So we will not really see anything besides security fixes.
    And the other part just says that Cpanel needs to get ready to work with the new 2.0 API. And sooner is better since you never know when the 1.3 version will be dropped all together by apache.org.

    And the argument that you hardly see Apache 2.x out there and therefore it is not good does not work at all. The reason that it is not offered with packages like Cpanel is the reason why it is hardly out there. It is really very simple, if you do not offer a product then most likely it will not be used :)

    cPanel.net Support Ticket Number:
     
  5. Erwin

    Erwin Member

    Joined:
    Apr 16, 2003
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Would WHM/ easyapache be updated for Apache 2.x at any stage soon? Just wondering...

    cPanel.net Support Ticket Number:
     
  6. lunaticss

    lunaticss Registered

    Joined:
    Sep 23, 2001
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Hey Erwin,

    Some how I do not think that they are going to do this anytime soon. Unfortunately.

    Personally I would like to get up to v2, but with my clients I need to maintain cpanel functionality. So I guess we are in a catch 22. :\

    BTW: I am GMTalk from vb.org and vb.com

    cPanel.net Support Ticket Number:
     
  7. Erwin

    Erwin Member

    Joined:
    Apr 16, 2003
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Hi,

    How did you know I'm the same Erwin? :)

    I do want to go up to Apache 2.0, but I do like cPanel's auto-update features... guess I'll have to wait. :)

    cPanel.net Support Ticket Number:
     
  8. lunaticss

    lunaticss Registered

    Joined:
    Sep 23, 2001
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    could be your homepage is set to http://www.vbulletin.org :) and I just assumed. heh

    cPanel.net Support Ticket Number:
     
  9. nyjimbo

    nyjimbo Well-Known Member

    Joined:
    Jan 25, 2003
    Messages:
    1,125
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    New York
    We have 2.0.47 running on 8 machines (non-Cpanel) and have ran it since 2.0.45.

    The compilation is somewhat different and its best going DSO for easier updating. However there are commands/directives that have changed in httpd.conf, especially SSL stuff which would require re-writing that file as a one-shot.

    But overall its not alot of changes, most of the modules that were available for 1.3.x seem to be fine with 2.0.4x. SSL/ModSSL is A LOT easier and Frontpage extensions are pretty straight forward. FP extensions do seem to require a couple extra lines in the virtualhosts .cnf files or webbot forms will not work properly.

    cPanel.net Support Ticket Number:
     
Loading...

Share This Page